7.7 Подключение пользователя к базе

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем morsh-irina, 13 авг 2008.

  1. TopicStarter Overlay
    morsh-irina
    Offline

    morsh-irina

    Регистрация:
    28 июл 2008
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    С помощью какой процедуры/функции можно подключить пользователя к базе?
    И как можно заполнить поле в отсчете, взяв из справочника элементы?
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Не совсем понятно, что вы имеете ввиду.
  3. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Точнее совсем не понятно, что вы имеете ввиду :)

    Единственное, что я понял, это два разных вопроса. morsh-irina
    попробуйте почитать тему "как правильно задать вопрос". Может кто и откликнится
  4. TopicStarter Overlay
    morsh-irina
    Offline

    morsh-irina

    Регистрация:
    28 июл 2008
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Прошу вас,кто-нибудь,подскажите...
    Необходимо написать программу,которая должна выполнять подключение пользователей к информационным базам,т.е. я на своем компьютере запускаю программу,а на комьютере у другого пользователя открывается нужная ему информационная база.
    Ниже моя программа, в которой не хватает подключения пользователя к инфо базе. Т.е выводятся все пользователи из справочника пользователей, таким же образом выводятся инфо базы, выбираю пользователя,выбираю базу. А как подключить их, не знаю. Надеюсь кто-нибудь откликнется,если знает как дописать эту программу. :unsure:

    Код:
    //*********-Моя программа-***********
    Перем ТекстФайла;
    Перем Сч; 
    Перем Текст; 
    Перем ВыбЗнач; 
    Перем Табл;
    Перем Спр;
    Перем Пользов; 
    Перем Парам; 
    Перем Знч; 
    Перем СпособВыборкиПользователей;
    Перем ВыбранноеПодразделение; 
    Перем СпрПользователи; 
    Перем ВыбПодразделение;
    Перем ВыбПользователь; 
    Перем Символ, Стр, Сч1, Сч2;
    
    //------------------------------------------------------------------------------ 
    Процедура ПриОткрытии() 
    
    ЗапуститьПриложение(КаталогИБ() + "PL1CConfReg.exe /exp");
    ЗапуститьПриложение(КаталогИБ() + "StartUp.");
    //Combobux вывести всех пользователей из справочника пользователей
    
    
    Спр = СоздатьОбъект("Справочник.Пользователи");
    
    // Польз.УдалитьВсе();
    Спр.ВыбратьЭлементы();
    
    Пока Спр.ПолучитьЭлемент() > 0 Цикл 
    Пользов = Спр.Наименование;
    // Польз.ДобавитьЗначение(Пользов); 
    КонецЦикла; 
    
    ///=================================================================
    
    // Символ = "лололожр";
    
    
    // Для Сч = 2 по СтрДлина(Стр) Цикл
    // 
    // Если Символ = " " Тогда
    // Возврат;
    // КонецЕсли; 
    
    // Сч1 = Сч1 + 1;
    // Сообщить(Символ);
    // Символ=Сред(Стр,Сч,1); 
    
    // КонецЦикла; 
    
    // Сообщить(Сч1); 
    ///================================================================= 
    КонецПроцедуры 
    
    //------------------------------------------------------------------------------
    Процедура Сформировать() 
    
    
    Если ФС.СуществуетФайл(КаталогИБ() + "Titles.ini") = 1 Тогда 
    
    ТекстФайла = СоздатьОбъект("Текст"); 
    ТекстФайла.Открыть(КаталогИБ() + "Titles.ini"); 
    ИнфБазы.УдалитьВсе();
    
    
    Для Сч=1 по ТекстФайла.КоличествоСтрок() Цикл
    
    Текст = ТекстФайла.ПолучитьСтроку(Сч); 
    
    Если (Лев(Текст,9) = "Загрузить") или (Лев(Текст,9) = "[Software") тогда
    Продолжить;
    КонецЕсли;
    
    
    Для Сч1 = 1 по СтрДлина(Текст) Цикл
    
    Символ=Сред(Стр,СтрДлина(Текст)-Сч1+1,1); 
    
    Если Символ = "" Тогда
    Возврат;
    КонецЕсли; 
    
    Сч2 = Сч2 + 1; 
    КонецЦикла; 
    
    
    ИнфБазы.ДобавитьЗначение(Прав(Текст,Сч2)); 
    
    КонецЦикла;
    КонецЕсли; КонецПроцедуры 
    //------------------------------------------------------------------------------
    Процедура Заполнить()
    
    Спр = СоздатьОбъект("Справочник.Пользователи");
    Спр.ВыбратьЭлементы();
    
    Список = СоздатьОбъект("СписокЗначений");
    // Список.ДобавитьЗначение(Знч);
    ОткрытьФорму("Справочник.Пользователи", Список); 
    
    КонецПроцедуры 
    
    Процедура Запустить_Приложение()
    
    перем Текст_Файла;
    Если ПустоеЗначение("ИнфоБазы") = 1 Тогда
    Сообщить("Выберите информационную базу");
    КонецЕсли;
    Если ПустоеЗначение("ВыбПользователя")=1 Тогда
    Сообщить("Выберите пользователя");
    КонецЕсли; 
    
    
    
    Текст_Файла = СоздатьОбъект("Текст");
    
    Текст_Файла.ДобавитьСтроку("Windows Registry Editor Version 5.00");
    Текст_Файла.ДобавитьСтроку("");
    Текст_Файла.ДобавитьСтроку("[HKEY_CURRENT_USERSoftware1C1Cv77.7Titles"+ИнфБазы+"StartUp]");
    //Текст_Файла.ДобавитьСтроку("""+"UserName"=""+ВыбПользователя+""");
    //Текст_Файла.ДобавитьСтроку("");
    
    Текст_Файла.Записать(КаталогИБ()+"Выгрузка.reg");
    
    ЗапуститьПриложение(КаталогИБ() + "Выгрузка.reg"); 
    КонецПроцедуры
    
    МОЖЕТ ПЕРЕСТАНЕМ ДУБЛИРОВАТЬ СООБЩЕНИЯ В РАЗНЫХ ТЕМАХ?
  5. Kaboom
    Offline

    Kaboom Опытный в 1С

    Регистрация:
    2 июл 2007
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    Я бы писал на Делфи: сервер у нас, и клиент у пользователя. Клиент висит в фоне, получает задания от сервера по сети и запускает 1С с нужной ИБ.
  6. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Писать подобное нет необходимости - оно есть как поставляемое MS например rsh, так и сторонних производителей в составе административных утилит. Т.е. на комп ставится серверная часть, у одмина клиент, который командует серверным частям, что делать. Ну, а то, что запустить нужную базу с нужным пользователем из командной строки, думаю не для кого не секрет...
  7. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    И хочу добавить, что код, написанный на 1С выполняется, когда уже загружена ИБ, но никак не до ее запуска.
    Так что вывод - 1С здесь нипричем, надо искать друние варианты

Поделиться этой страницей