8.х ОБМЕН Подключение из 1С 7 к 1С 8.2

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем Davids_777, 4 июл 2012.

  1. TopicStarter Overlay
    Davids_777
    Offline

    Davids_777

    Регистрация:
    6 авг 2011
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Люди!!!!!!!!!! Это капец!!!!!!!! Помогите!!!!!!!!!!! Есть обработка (1С 7), которая должна установить соединение с 1С 8.2. Ну всё сделал уже, зарегил компоненту comcntr.dll, обработка выполняется, но по концу выскакиевает модальное окно: Возвращаемая строка превысит допустимый предел! Что это за х....ня?????((((( Блин я не найду в гугле решения есть только два ответа на этот вопрос и то хреновых(((((((

    Процедура Выполнить()
    НовоеПодключение = СоздатьОбъект("V82.COMConnector");
    СтрокаПодключения = "file=""\\192.168.5.1\public\Гайна Д.И\Базы_1С\Extra_UTP"";usr=""david"";pwd=""485963"";";
    Попытка
    Подключение = НовоеПодключение.Connect(СтрокаПодключения);
    Сообщить("Ура!");
    Исключение
    Сообщить(ОписаниеОшибки());
    КонецПопытки;

    КонецПроцедуры
  2. TopicStarter Overlay
    Davids_777
    Offline

    Davids_777

    Регистрация:
    6 авг 2011
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Ну ребят, ну подскажите?!!! Очень надо!!!
  3. Бухгалтерский угодник
    Online

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Если окно выскакивает значит компонента подключается. Иначе ругалась бы в окне сообщений. А тут - модальное окно.
    Выложите обработку. Подобное сообщение выскакивает скажем если в тексте запроса накосячить
  4. TopicStarter Overlay
    Davids_777
    Offline

    Davids_777

    Регистрация:
    6 авг 2011
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Так вот же она:

    Код:
    Процедура Выполнить()
    НовоеПодключение = СоздатьОбъект("V82.COMConnector");
    СтрокаПодключения = "file=""\\192.168.5.1\public\Гайна Д.И\Базы_1С\Extra_UTP"";usr=""david"";pwd=""485963"";";
    Попытка
    Подключение = НовоеПодключение.Connect(СтрокаПодключения);
    Сообщить("Ура!");
    Исключение
    Сообщить(ОписаниеОшибки());
    КонецПопытки;
    КонецПроцедуры
  5. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Где ?
    И оформляйте код тегами
    Код:
    
    
  6. TopicStarter Overlay
    Davids_777
    Offline

    Davids_777

    Регистрация:
    6 авг 2011
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    Вот:

    Код:
    Процедура Выполнить()
    НовоеПодключение = СоздатьОбъект("V82.COMConnector");
    СтрокаПодключения = "file=""\\192.168.5.1\public\Гайна Д.И\Базы_1С\Extra_UTP"";usr=""david"";pwd=""485963"";";
    Попытка
    Подключение = НовоеПодключение.Connect(СтрокаПодключения);
    Сообщить("Ура!");
    Исключение
    Сообщить(ОписаниеОшибки());
    КонецПопытки;
    
    КонецПроцедуры
    Уже разобрался! Модальное окно выдавалось с помощью Сообщить(ОписаниеОшибки()). А когда я вставил Сообщить(Лев(ОписаниеОшибки(),250)); стало выдавать другую ошибку без модального окна:

    V82.COMConnector.1: Не найдена лицензия. Не обнаружен ключ защиты программы или полученная программная лицензия!
    Поиск лицензии на клиенте:
    Ошибка программного лицензирования
    Ошибка привязки программной лицензии к компьютеру: file://d:/bin/conf/20120

    А теперь когда я установил на тот комп с которого коннекчусь и на котором стоит 1С 7 установил 1С 8, взломал! И все заработало на УРА!!!!

    Спасибо товарисчи по содействию!!!!!!!!!
  7. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Это компонента :)))))))))) ?
  8. TopicStarter Overlay
    Davids_777
    Offline

    Davids_777

    Регистрация:
    6 авг 2011
    Сообщения:
    25
    Симпатии:
    0
    Баллы:
    1
    ты прикалуешься???? сначало читай внимательно!!!! а потом пиши свои намешки!!!!!!!!!!
Похожие темы
  1. Shelest
    Ответов:
    4
    Просмотров:
    2.826
  2. Will
    Ответов:
    6
    Просмотров:
    2.332
Загрузка...

Поделиться этой страницей