7.7 Подключение эквайринга в 1С Тис 9.2

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем zolotov, 26 окт 2015.

  1. TopicStarter Overlay
    zolotov
    Offline

    zolotov

    Регистрация:
    2 окт 2015
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Добрый день! Кто может помочь с проблеммой отзовитесь! Обработка SBRF.ERT. При нажатии кнопок ОПЛАТИТЬ БАНКОВСКОЙ КАРТОЙ выдается ошибка: Amount = Serv.SParam ("Amount", Сумма);
    {C:\1CBASE\КОПИЯ DB\EXTFORMS\SBRF.ERT(61)}: Значение не представляет агрегатный объект (SParam). На других кнопках тоже ошибки. Т.е. обработка не работает. Как решить проблемму?
  2. Катюфка
    Offline

    Катюфка Профессионал в 1С

    Регистрация:
    3 июн 2013
    Сообщения:
    403
    Симпатии:
    71
    Баллы:
    54
    Если библиотеки установлены, то попробуйте запустить 1С с правами администратора.
  3. TopicStarter Overlay
    zolotov
    Offline

    zolotov

    Регистрация:
    2 окт 2015
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    1С так и запущена с правами администратора
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Возможно нужно зарегистрировать библу в регистре
  5. TopicStarter Overlay
    zolotov
    Offline

    zolotov

    Регистрация:
    2 окт 2015
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Дружище, а расскажи как это сделать?
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
  7. TopicStarter Overlay
    zolotov
    Offline

    zolotov

    Регистрация:
    2 окт 2015
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Библиотеки sbrf.dll, sbrfcom.dll, sb_1c.dll зарегистрированы именно так. Единственно что при регистриции библиотек pilot_nt.dll, sb_kernel.dll, gate.dll выскакивает вот такая надпись "C:\Program Files\1Cv77\BIN\ИмяБиблиотеки была загружена, но найти точку входа для DllRegisterServer не удалось. Зарегистрировать этот файл не возможно."
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Вы делали от имени администратора?
  9. TopicStarter Overlay
    zolotov
    Offline

    zolotov

    Регистрация:
    2 окт 2015
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Вход в 1С и загрузка ОС я осуществляю только под администратором
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Если у вас Windows 7 или 8 это не играет роли.
  11. TopicStarter Overlay
    zolotov
    Offline

    zolotov

    Регистрация:
    2 окт 2015
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    У меня Windows XP Professional Service Park 2
  12. TopicStarter Overlay
    zolotov
    Offline

    zolotov

    Регистрация:
    2 окт 2015
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Может каким то образом моя ОС (Windows XP Professional Service Park 2) влиять на работу обработки?
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Маловероятно. Почему-то у вас не создается объект.
    Выложите саму обработку.
  14. TopicStarter Overlay
    zolotov
    Offline

    zolotov

    Регистрация:
    2 окт 2015
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Обработка

    Вложения:

    • SBRF.rar
      Размер файла:
      8,2 КБ
      Просмотров:
      40
  15. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    1) Попробуйте указать ПОЛНЫЙ путь до библы при запуске
    2) Попробуйте ДО метода передачи параметров вызвать очистку.

    Serv.Clear(); //вот тут будет ли ошибка
    Amount = Serv.SParam ("Amount", Сумма);
  16. TopicStarter Overlay
    zolotov
    Offline

    zolotov

    Регистрация:
    2 окт 2015
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    К сожалению я не имею опыта програмиста....(((
  17. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Нужно в конфигураторе открыть обработку и вставить код
    Serv.Clear();
    в строку №60. Сохраните и попытайтесь выполнить
  18. TopicStarter Overlay
    zolotov
    Offline

    zolotov

    Регистрация:
    2 окт 2015
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Вставил как Вы сказали (выделено синим цветом). Выдало вот такую ошибку:

    Serv.Clear();
    {C:\1CBASE\КОПИЯ DB\EXTFORMS\SBRF.ERT(60)}: Значение не представляет агрегатный объект (Clear)

    Процедура ОплатаКартой()
    Serv.Clear();
    Amount = Serv.SParam ("Amount", Сумма);
    Если Serv.NFun (4000) <> 0 Тогда
    Предупреждение("Операция с банком не удалась! Попробуйте еще раз.");
    СтатусВозврата(0);
    Возврат;
    МожноПровестиЧекККМ = 0 ;
    Иначе
    TermNum = Serv.GParamString("TermNum");
    ClientCard = Serv.GParamString("ClientCard");
    ClientExpiryDate = Serv.GParamString("ClientExpiryDate");
    AuthCode = Serv.GParamString("AuthCode");

    cheque = Serv.GParamString("cheque");
    ECR.Caption = cheque;
    ECR.TextWrap=1;
    Если ECR.PrintString() <> 0 Тогда
    Serv.NFun (6004);
    Предупреждение("Не удалось распечатать Чек операции!
    |Операция с банком не удалась!!!
    |Включите ККМ или замените ленту и попробуйте еще раз!!!)",60);
    МожноПровестиЧекККМ = 0 ;
    СтатусВозврата(0);
    Возврат;
    Иначе
    МожноПровестиЧекККМ = 1 ;
    Форма.Закрыть(1);
    КонецЕсли;

    Для СчПустыхСтрок=1 По 6 Цикл
    ECR.Caption = " ";
    Если ECR.PrintString() <> 0 Тогда
    Сообщить("не напечатали ---");
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;

    КонецПроцедуры // ОплатаКартой()
  19. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Ну значит у вас точно не создается объект! Никаких сообщений при старте обработке не появляется?
  20. TopicStarter Overlay
    zolotov
    Offline

    zolotov

    Регистрация:
    2 окт 2015
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Нет, обработка открывается без ошибок! А при нажатии кнопок вылезают ошибки.

Поделиться этой страницей