Курилка Подготовка к экзамену "1С:Специалист" по типовому решению "Управление торговлей"

Тема в разделе "Курилка", создана пользователем Jaivan, 30 окт 2007.

  1. TopicStarter Overlay
    Jaivan
    Offline

    Jaivan Опытный в 1С

    Регистрация:
    24 апр 2007
    Сообщения:
    79
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, уважаемые форумчане!
    Идея создания этой темы обусловлена собственно заинтересованностью в должной подготовке к указанному экзамену и обсуждению правильности реализации того или иного примера из хорошо известного док файла ATT80UT (http://www.1c.ru/rus/partners/training/files/att80ut.zip).
    Надеюсь среди многих из вас найдутся, те, у кого имеются вопросы/ответы связанные с этой темой....
  2. TopicStarter Overlay
    Jaivan
    Offline

    Jaivan Опытный в 1С

    Регистрация:
    24 апр 2007
    Сообщения:
    79
    Симпатии:
    0
    Баллы:
    26
    Конкретно интересуют следующие вопросы:
    - к заданию по реализации сопутствующих товаров
    1. правильной ли является реализация для группы определять состав сопутствующих товаров со след. кодом:
    Код:
    Процедура ПриЗаписи()
    если товары.Количество() > 0 тогда
    запрос = новый запрос;
    запрос.Текст = "
    |выбрать различные Ссылка из справочник.номенклатура где родитель = &род";
    запрос.УстановитьПараметр("род", этотобъект.ссылка);
    результат = запрос.Выполнить().Выбрать();
    Пока результат.Следующий() цикл
    номенкл = результат.ссылка.получитьобъект();
    для каждого строка из товары цикл
    Объект = строка.номенклатура.ПолучитьОбъект();
    Объект.сопутствующий = Истина;
    Объект.Записать();
    пров = номенкл.товары.Найти(строка.номенклатура, "Номенклатура");
    если пров = неопределено тогда
    запись = номенкл.товары.добавить();
    запись.номенклатура = строка.номенклатура;
    Иначе
    Сообщить("Сопутствующий товар " + строка.номенклатура + " уже добавлен товару" + номенкл);
    Продолжить;
    КонецЕсли;
    конеццикла;
    номенкл.записать();
    КонецЦикла;
    Иначе
    запрос = новый запрос;
    запрос.Текст = "
    |выбрать различные Ссылка из справочник.номенклатура где родитель = &род";
    запрос.УстановитьПараметр("род", этотобъект.ссылка);
    результат = запрос.Выполнить().Выбрать(); 
    Пока результат.Следующий() цикл
    номенкл = результат.ссылка.получитьобъект();
    Для каждого строка Из номенкл.Товары Цикл
    Объект = строка.номенклатура.ПолучитьОбъект();
    Объект.Сопутствующий = Ложь;
    Объект.Записать();
    
    КонецЦикла;
    
    Если номенкл.Товары.Количество() > 0 Тогда
    Номенкл.Товары.Очистить();
    КонецЕсли;
    номенкл.записать();
    КонецЦикла;
    КонецЕсли;
    КонецПроцедуры;
    
    2. обязательна ли проверка на уже добавленный сопутствующий товар?
    3. достаточным ли является организация подбора сопутствующего товара на примере реализации?
    4. допустимым ли является организация подбора через таблицу значений следующим образом:
    Код:
    Процедура ТоварыНоменклатураНачалоВыбора(Элемент, СтандартнаяОбработка)
    Если РежимПодбора = Истина Тогда;
    СтандартнаяОбработка = Ложь;
    Для каждого Строка Из Товары Цикл
    Если Строка.Номенклатура.Товары.Количество() > 0 Тогда
    ТЗ = Строка.Номенклатура.Товары.Выгрузить();
    ВыбрСтрока = ТЗ.ВыбратьСтроку("Обнаружены сопутствующие товары у позиции " + Строка.Номенклатура + ": ");
    Если ВыбрСтрока = Неопределено Тогда
    Продолжить;
    КонецЕсли;
    Элемент.Значение = ВыбрСтрока.Номенклатура;
    Прервать;
    Иначе
    СтандартнаяОбработка = Истина;
    КонецЕсли;
    КонецЦикла;
    Иначе
    СтандартнаяОбработка = Истина;
    КонецЕсли;
    КонецПроцедуры
    
    Процедура КоманднаяПанельТоварыДействие10(Кнопка)
    РежимПодбора = ?(РежимПодбора = Истина, Ложь, Истина);
    Если РежимПодбора = Истина Тогда
    Кнопка.Текст = "Режим подбора (ОК)";
    Иначе
    Кнопка.Текст = "Режим подбора";
    КонецЕсли;
    
    КонецПроцедуры
    
    
    Кто-нибудь может поделиться примерами заданий с самого экзамена?
    Заранее спасибо! :)

    Используйте тэг
    Код:
    [/color]
  3. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Предполагаю, что многим просто лениво будет разбирать неотформатированный текст...
  4. TopicStarter Overlay
    Jaivan
    Offline

    Jaivan Опытный в 1С

    Регистрация:
    24 апр 2007
    Сообщения:
    79
    Симпатии:
    0
    Баллы:
    26
    ИМХО предполагается, что тема будет в первую очередь полезна тем, кто так же подготавливается к экзамену и отформатирован ли или нет текс для него будет не принципиально важно.

Поделиться этой страницей