7.7 Подчиненный справочник

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Time dont wait, 22 окт 2009.

  1. TopicStarter Overlay
    Time dont wait
    Offline

    Time dont wait Опытный в 1С

    Регистрация:
    20 окт 2009
    Сообщения:
    192
    Симпатии:
    0
    Баллы:
    26
    Суть проблемы:
    Есть СпрСотрудники, в форме списка которого открываю форму выбраного елемента, там есть кнопка с процедурой, которая должна вызывать форму елемента подчиненного справочника для редактирования.Владельцы заданы, все вроде в порядке, но при нажатии на кнопку ничего не происходит, ни ошибки, ни результата
    спрКадровыеДанные - подчиненный
    Вот код:
    Код:
    Процедура ВызватьКД()
    Если Выбран()=1 Тогда
    КонтФормы=0;
    ОткрытьФорму("Справочники.КадровыеДанные.ФормаЭлемента",ТекущийЭлемент(),КонтФормы);
    КонецЕсли;
    КонецПроцедуры 
    
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    КадровыеДанные - это подчиненный справочник?
  3. TopicStarter Overlay
    Time dont wait
    Offline

    Time dont wait Опытный в 1С

    Регистрация:
    20 окт 2009
    Сообщения:
    192
    Симпатии:
    0
    Баллы:
    26
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Кадры=СоздатьОбъект("Справочники.КадровыеДанные");
    Кадры.ИспользоватьВладельца(ТекущийЭлемент());
    Если Кадры.ВыбраратьЭлементы()=1 Тогда
    Кадры.ПолучитьЭлемент();
    ОткрытьФорму(Кадры.ТекущийЭлемент());
    КонецЕсли;
    
    
    //откроется первый элемент КадровыеДанные
  5. TopicStarter Overlay
    Time dont wait
    Offline

    Time dont wait Опытный в 1С

    Регистрация:
    20 окт 2009
    Сообщения:
    192
    Симпатии:
    0
    Баллы:
    26
    Большое спасиба))
  6. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    ОткрытьФорму("Справочники.КадровыеДанные.ФормаЭлемента",ТекущийЭлемент(),КонтФормы);

    просто посмотри параметры вызова

Поделиться этой страницей