7.7 Подчиненный справочник

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Dmitrij, 25 июн 2009.

  1. TopicStarter Overlay
    Dmitrij
    Offline

    Dmitrij Опытный в 1С

    Регистрация:
    6 май 2008
    Сообщения:
    844
    Симпатии:
    1
    Баллы:
    26
    Подскажите, я вывожу отчет: все данные из справочника товары, мне нужны данные из справочника единицы измерения как мне вытащить данные из справочника единицы измерения именно для позиции из справочника товары
    например: товар А=ед изм В
    :unsure:
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Товар.ВыбратьЭлементы();
    Пока Товар.ПолучитьЭлемент()=1 Цикл
    Если Товар.ЭтоГруппа()=1 Тогда
    Продолжить;
    КонецЕсли;
    Ед.ИспользоватьВладельца(Товар.ТекущийЭлемент());
    Ед.ВыбратьЭлементы();
    Пока Ед.ПолучитьЭлемент()=1 Цикл
    //.......... делай что нужно
    КонецЦикла;
    КонецЦикла;
    
    
  3. TopicStarter Overlay
    Dmitrij
    Offline

    Dmitrij Опытный в 1С

    Регистрация:
    6 май 2008
    Сообщения:
    844
    Симпатии:
    1
    Баллы:
    26
    Забыл отметить, можно ли это сделать через запрос
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Все реально.... Конструктор запросов тебе в руки!
  5. TopicStarter Overlay
    Dmitrij
    Offline

    Dmitrij Опытный в 1С

    Регистрация:
    6 май 2008
    Сообщения:
    844
    Симпатии:
    1
    Баллы:
    26
    а примерчик можно
  6. ASh
    Offline

    ASh Опытный в 1С

    Регистрация:
    10 сен 2008
    Сообщения:
    568
    Симпатии:
    0
    Баллы:
    26
    Код:
    //В ТекТовар должен быть выбран интересующий нас товар
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = "
    |ЕдИзм = Справочник.ЕдиницыИзмерения.ТекущийЭлемент;
    |Владелец = Справочник.ЕдиницыИзмерения.Владелец;
    |Группировка ЕдИзм;
    |Условие(Владелец=ТекТовар);
    |";
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;
    Пока Запрос.Группировка(1) = 1 Цикл
    // Получаем данные через Запрос.ЕдИзм
    КонецЦикла;
    
    Если конфа типовая, то данные нужно тащить из справочника "Единицы" и выбирать от туда ОКЕИ

Поделиться этой страницей