7.7 Подчиненные справочники

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем DIO, 14 окт 2010.

  1. TopicStarter Overlay
    DIO
    Offline

    DIO

    Регистрация:
    19 июл 2007
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Есть справочник Контрагенты и подчиненный справочник Лицензии. Идея в том, чтоб из формы элемента справочник Контрагенты вызывать форму списка справочника Лицензии, выбирать там нужный элемент и прописывать его в в реквизиты справочник Контрагенты. В справочнике Контрагенты вешаю кнопку с процедурой :
    Код:
    Процедура ВыбЛицензии()
    ОткрытьФорму("Справочник.Лицензии", Контекст);
    КонецПроцедуры
    В подчиненном справочнике :
    Процедура ПриОткрытии()
    Спр = СоздатьОбъект("Справочник.Лицензии");
    Спр.ИспользоватьВладельца(Форма.Параметр);
    КонецПроцедуры
    Всё открывается отлично, затем в форме списка вешаю кнопоку с процедурой:
    Процедура Уст()
    Если Выбран() = 1 Тогда
    Клн = СоздатьОбъект("Справочник.Клиенты");
    Пер = ТекущийЭлемент().Владелец;
    Если Клн.НайтиЭлемент(Пер) = 1 Тогда
    Нужный = Клн.ТекущийЭлемент();
    Нужный.СерияЛиц = Серия;
    Нужный.Лицензия = Номер; 
    Нужный.Записать();
    Форма.Закрыть();
    КонецЕсли;
    КонецЕсли;
    КонецПроцедуры
    При нажатии этой кнопочки выдаёт ошибку :
    Нужный.Записать();
    {Справочник.Лицензии.ФормаСписка.ФормаСписка.Модуль(16)}: <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/не')">Не выбран элемент!</span>
    
    
    Подскажите, пожалуйста, где я не прав?
  2. PavelBaryshev
    Offline

    PavelBaryshev Опытный в 1С

    Регистрация:
    9 сен 2008
    Сообщения:
    316
    Симпатии:
    0
    Баллы:
    26
    так ты каждый раз при открытии справочника лицензии создаешь новый элемент, может надо передавать парамметр при выполнении процедуры открытия справочника лицензий, а там при открытии смотреть ели параметр истина то создавать новый элемент.
  3. TopicStarter Overlay
    DIO
    Offline

    DIO

    Регистрация:
    19 июл 2007
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Дак в том то и дело, сто открывается то он классно, и элементы новые создаются без проблем, а вот записать из него данные и справочник владелец не получается
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    В форму списка вы уже передали контекст форму. Ну и присваивайте текущий выбранный реквизит...
    Код:
    Перем Конт;
    Процедура ПриОткрытии()    
    Спр = СоздатьОбъект("Справочник.Лицензии");    Спр.ИспользоватьВладельца(Форма.Параметр);
    Конт=Форма.Параметр;
    КонецПроцедуры
    
    Процедура Уст()
    Если Выбран() = 1 Тогда    
    Конт.Лицензия=ТекущийЭлемент()
    Форма.Закрыть();        
    КонецЕсли;
    КонецПроцедуры
    
    

Поделиться этой страницей