[РЕШЕНО] Подчеркивание текста в области ячейки

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем alexburn, 16 окт 2014.

  1. TopicStarter Overlay
    alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Приветствую вас, собратья:)!
    У меня вопросик такой. Каким образом можно изменить шрифт в ячейке, пишу такой код:
    Код:
    Макет.Области.Личная.Шрифт = Новый Шрифт(,,,,,ИСТИНА,,);
    Где соответственно нужной области присвоил имя Личная.
    Такой код не прокатывает :(
    Может что-то в макете нужно сделать, например, снять защиту с ячейки ?
  2. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.975
    Симпатии:
    397
    Баллы:
    104
    Привет. У меня есть пример где я фон ячейки менял. Там же и до шрифта не далеко :)
    Код:
    // WebЦвета.ХакиТемный этот цвет приятный на вид и при распечатки на нецветном принтеревидно хорошо видно содержимое ячейки.
    // Изменяет фон ячеек со значениями Суббота и воскресенье.
    // ................................................................................
    Процедура ИзменениеФонаЯчейкиМакета(Макет, ТабДок, ИмяДляПоиска, Префикс, КоличествоПозиций)
       
        Если Префикс = "ЗН" Тогда
            Для каждого ТекСтрока Из ИмяДляПоиска Цикл
                ИмяЯчейки = Макет.НайтиТекст(Префикс + ТекСтрока.НомерДняНедели);
                Если Лев(Прав(ИмяЯчейки.Имя, 2),1) = "C" Тогда
                    НачалоОтсчета = Число(Лев(Прав(ИмяЯчейки.Имя, 3),1));
                Иначе
                    НачалоОтсчета = Число(Лев(Прав(ИмяЯчейки.Имя, 4),1));
                КонецЕсли;
                Для i=1 По КоличествоПозиций Цикл
                    НачалоЯчейки = "R";
                    Если i=1 Тогда
                        НачалоОтсчета = НачалоОтсчета;
                    Иначе
                        НачалоОтсчета = НачалоОтсчета + 1;
                    КонецЕсли;
                    Если Лев(Прав(ИмяЯчейки.Имя, 2),1) = "C" Тогда
                        КонецЯчейки = Прав(ИмяЯчейки.Имя, 2);
                    Иначе
                        КонецЯчейки = Прав(ИмяЯчейки.Имя, 3);
                    КонецЕсли;
                    СобраннаяЯчейка = НачалоЯчейки + Строка((НачалоОтсчета)) + КонецЯчейки;
                    Ячейка = ТабДок.Область(СобраннаяЯчейка);
                    Если Ячейка <> Неопределено Тогда
                        Ячейка.ЦветФона = WebЦвета.ХакиТемный;
                    КонецЕсли;
                КонецЦикла;
            КонецЦикла;
        Иначе
            Для каждого ТекСтрока Из ИмяДляПоиска Цикл
                ИмяЯчейки = Макет.НайтиТекст(Префикс + ТекСтрока.НомерДняНедели);
                Ячейка = ТабДок.Область(ИмяЯчейки.Имя);
                Если Ячейка <> Неопределено Тогда
                    Ячейка.ЦветФона = WebЦвета.ХакиТемный;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
    
    КонецПроцедуры
  3. TopicStarter Overlay
    alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Ну у меня по сути то же самое:
    Код:
    ТабДок.Область(СобраннаяЯчейка).ЦветФона = WebЦвета.ХакиТемный;
    Только:
    Код:
    Макет.Область("Личная").Шрифт = Новый Шрифт(,,,,,ИСТИНА,,);
    --- Объединение сообщений, 16 окт 2014 ---
    Т.е. переправил Области на Область, но ничего не изменилось :(
  4. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.975
    Симпатии:
    397
    Баллы:
    104
    Блин, а ты саму ячейку то вообще получаешь? Отладчик что говорит?
  5. TopicStarter Overlay
    alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Отладчиком не могу воспользоваться, сервер не запущен в режиме отладки. Я так, методом тыка сейчас пробую :)
  6. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.975
    Симпатии:
    397
    Баллы:
    104
    Печаль. Я просто помню, что сам долго тыркался. Но у меня хоть отладчик был. Локальную запусти. А то до завтра будешь метод тыка пробовать :D
    alexburn нравится это.
  7. TopicStarter Overlay
    alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Ок, спасибо, буду дальше тыркать:). В файловом что-то не хочется отлаживать :)
  8. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.975
    Симпатии:
    397
    Баллы:
    104
    Да ладно ты. Если это макет, то нормально :)
  9. TopicStarter Overlay
    alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Гемор просто выгружать скульную базу, на разворот в файловую может уйти много времени :), я вот о чем
  10. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.975
    Симпатии:
    397
    Баллы:
    104
    Слушай, а зачем сервер в режиме отладки запускать? Средствами 1С же все делается.
  11. TopicStarter Overlay
    alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    :D отладчик в серверные процедуры не зайдет, на клиенте - спокойно. Но так как процедура печати расположена в менеджере объекта в серверной процедуре, то и отладчик туда не зайдет.
  12. nbIpKuH_BaH9I
    Offline

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.975
    Симпатии:
    397
    Баллы:
    104
    А. Понял. Ну тогда удачи... :)
  13. TopicStarter Overlay
    alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Костя, я сам просто туплю, нужно было так:
    Код:
    ОбластьМакета.Области.ИмяОбласти.Шрифт = Новый Шрифт(,,,,,ИСТИНА,,);
    Все заработало :)

Поделиться этой страницей