8.х Почему-то не проверяет на незаполненные значения?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Nicom77, 23 авг 2010.

  1. TopicStarter Overlay
    Nicom77
    Offline

    Nicom77

    Регистрация:
    18 авг 2010
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    При проведении расходного документа не проверяется запрет незаполненного значения, хотя галочка стоит (в регистре накопления, в измерениях), а так же не создаётся движение документа при незаполненных или неправильно (т.е. заполненно не тем значением из справочника) заполненных значениях полей, но запись о документе в основную форму списка расходного документа добавляется. В чём может быть проблема?

    Код:
    Процедура ОбработкаПроведения(Отказ, Режим)
    Запрос = Новый Запрос;
    Запрос.Текст = "
    |	ВЫБРАТЬ
    |	Наименование,
    |	РеальноеНаименование,
    |	ВидУчётаЭТЦ,
    |	ВОЛП,
    |	ПусковойКомплекс,
    |	ОбъектУчасток,
    //	|//	СерийныйНомер,
    //	|//	ИнвентарныйНомер,
    |	СУММА (Количество) КАК Количество,
    |	ВидУчётаБухгалтерии,
    |	ВидМС
    |ПОМЕСТИТЬ ВрРасхТаб
    |ИЗ
    |	Документ.РасходныеДокументы.МатериальныеСредства
    |ГДЕ
    |	Ссылка = &Ссылка
    |СГРУППИРОВАТЬ ПО 
    |	Наименование,
    |	ВидУчётаЭТЦ, 
    |	ВОЛП, 
    |	ПусковойКомплекс, 
    |	ОбъектУчасток,
    |	СерийныйНомер,
    |	ИнвентарныйНомер,
    |	ВидУчётаБухгалтерии,
    |	ВидМС,
    |	РеальноеНаименование
    |;
    |ВЫБРАТЬ
    |	ВрРасхТаб.Наименование,
    |	ВрРасхТаб.ВидУчётаЭТЦ,
    |	ВрРасхТаб.ВОЛП,
    |	ВрРасхТаб.ПусковойКомплекс,
    |	ВрРасхТаб.ОбъектУчасток,
    //	|//	ВрРасхТаб.СерийныйНомер,
    //	|//	ВрРасхТаб.ИнвентарныйНомер,
    |	ВрРасхТаб.Количество,
    |	ВрРасхТаб.ВидУчётаБухгалтерии,
    |	ВрРасхТаб.ВидМС,
    |	ВрРасхТаб.РеальноеНаименование,
    |	Остатки.ВидУчётаЭТЦ,
    |	Остатки.ВОЛП,
    |	Остатки.ПусковойКомплекс,
    |	Остатки.ОбъектУчасток,
    |	ЕСТЬNULL(Остатки.КоличествоОстаток, 0) КАК КоличествоОстаток
    |ИЗ 
    |	ВрРасхТаб КАК ВрРасхТаб
    |ЛЕВОЕ СОЕДИНЕНИЕ
    |	РегистрНакопления.ОстаткиМатериалов.Остатки (&МоментВремени, Наименование В(ВЫБРАТЬ А.Наименование ИЗ ВрРасхТаб КАК А)) КАК Остатки
    |	ПО ВрРасхТаб.Наименование = Остатки.Наименование
    |ГДЕ 
    |	Остатки.ВидУчётаЭТЦ ЕСТЬ NULL ИЛИ Остатки.ВидУчётаЭТЦ = ВрРасхТаб.ВидУчётаЭТЦ И
    |	Остатки.ВОЛП ЕСТЬ NULL ИЛИ	Остатки.ВОЛП = ВрРасхТаб.ВОЛП И
    |	Остатки.ПусковойКомплекс ЕСТЬ NULL ИЛИ Остатки.ПусковойКомплекс = ВрРасхТаб.ПусковойКомплекс И
    |	Остатки.ОбъектУчасток ЕСТЬ NULL ИЛИ Остатки.ОбъектУчасток = ВрРасхТаб.ОбъектУчасток И
    |	Остатки.РеальноеНаименование ЕСТЬ NULL ИЛИ Остатки.РеальноеНаименование=ВрРасхТаб.РеальноеНаименование И
    |	Остатки.ВидУчётаБухгалтерии ЕСТЬ NULL ИЛИ Остатки.ВидУчётаБухгалтерии=ВрРасхТаб.ВидУчётаБухгалтерии";
    
    Запрос.УстановитьПараметр ("Ссылка", Ссылка);
    Запрос.УстановитьПараметр ("МоментВремени", МоментВремени());
    РезультатЗапроса = Запрос.Выполнить();
    Выборка=РезультатЗапроса.Выбрать();
    Пока Выборка.Следующий () Цикл
    Если Выборка.Количество>Выборка.КоличествоОстаток Тогда
    Сообщить("Мало товара " + Выборка.Наименование + ", из необходимых " 
    + Выборка.Количество + " в наличии имеется только " + Выборка.КоличествоОстаток); 
    Отказ=Истина
    КонецЕсли;		
    КонецЦикла; 
    
    Если Отказ Тогда
    Возврат;
    КонецЕсли;	
    
    Выборка.Сбросить();	
    //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
    Пока Выборка.Следующий () Цикл
    // регистр ОстаткиМатериалов Расход
    Движение = Движения.ОстаткиМатериалов.Добавить();
    Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
    Движение.Период = Дата;
    Движение.Контрагенты = Контрагенты;
    Движение.Наименование = Выборка.Наименование;
    Движение.ВидУчётаЭТЦ = Выборка.ВидУчётаЭТЦ;
    Движение.ОбъектУчасток = Выборка.ОбъектУчасток;
    Движение.ВидУчётаБухгалтерии = Выборка.ВидУчётаБухгалтерии;
    Движение.ПусковойКомплекс = Выборка.ПусковойКомплекс;
    Движение.ВидМС = Выборка.ВидМС;
    //	Движение.СерийныйНомер = Выборка.СерийныйНомер;
    //	Движение.ИнвентарныйНомер = Выборка.ИнвентарныйНомер;
    Движение.МатериальноОтветственноеЛицо = МатериальноОтветственноеЛицо;
    Движение.РеальноеНаименование = Выборка.РеальноеНаименование;
    Движение.ВОЛП = Выборка.ВОЛП;
    Движение.Количество = Выборка.Количество;
    КонецЦикла;
    //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    КонецПроцедуры
    
    
  2. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Здраствуйте!
    Документ указан как регистратор?
Похожие темы
  1. Pilgrim
    Ответов:
    0
    Просмотров:
    1.119
  2. Колесо
    Ответов:
    1
    Просмотров:
    376
  3. desintegrer
    Ответов:
    1
    Просмотров:
    378
  4. Незнайка это Я
    Ответов:
    5
    Просмотров:
    336
  5. kulkrise
    Ответов:
    5
    Просмотров:
    471
Загрузка...

Поделиться этой страницей