8.х Почему не запускается обработка?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Dimka77, 27 фев 2010.

  1. TopicStarter Overlay
    Dimka77
    Offline

    Dimka77 Опытный в 1С

    Регистрация:
    6 июн 2009
    Сообщения:
    279
    Симпатии:
    0
    Баллы:
    26
    Создал объект "Общего модуля", туда положил такой код:
    Код:
    Процедура НачалоЗагрузки () Экспорт;
    Сообщить("Начало Обработки " +ТекущаяДата());	
    Обработки.ПриветМир();
    Сообщить("Конец Обработки " +ТекущаяДата());
    КонецПроцедуры
    
    Создал "Обработку", там следующий код в модуле объекта:
    Код:
    Процедура ПриветМир () Экспорт;
    Сообщить ("Привет Мир");
    КонецПроцедуры
    
    
    Запускаю общий модуль по расписанию, вот что получается:
    Почему нет "Привет Мир"?
  2. TopicStarter Overlay
    Dimka77
    Offline

    Dimka77 Опытный в 1С

    Регистрация:
    6 июн 2009
    Сообщения:
    279
    Симпатии:
    0
    Баллы:
    26
    Всё разобрался, яндекс рулит! :)
  3. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Здраствуйте!
    Когда самостоятельно находите ответ, просьба писать решение своей задачи, давайте будет уважать наших молодых программистов которые возможно будут юзать эту страничку дабы разобраться точно с таким же вопросом. Благодарю!
  4. TopicStarter Overlay
    Dimka77
    Offline

    Dimka77 Опытный в 1С

    Регистрация:
    6 июн 2009
    Сообщения:
    279
    Симпатии:
    0
    Баллы:
    26
    Прошу прощения вот ответ:
    Так обработка не запускается, её в принципе запустить нельзя, потому как можно запустить только процедуру/функцию из неё, этот ответ я смог найти здесь Сайт

    Правильно было так:
    Код:
    Процедура НачалоЗагрузки () Экспорт;
    Сообщить("Начало Обработки " +ТекущаяДата());	
    Обр = Обработки.ПриветМир.Создать();
    Обр.ПриветМир();
    Сообщить("Конец Обработки " +ТекущаяДата());
    КонецПроцедуры
    

Поделиться этой страницей