8.х Почему не записывается реквизит в табличную часть?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем tumanovalex, 15 окт 2006.

  1. TopicStarter Overlay
    tumanovalex
    Offline

    tumanovalex

    Регистрация:
    3 июл 2006
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    В табличную часть документа ввел новый реквизит ДатаПродажи. С помощью обработки хотел записать в каждую строку табличной части дату документов продажи:
    Процедура КнопкаВыполнитьНажатие(Элемент)
    ВыборкаДокументов = Документы.ОтчетКомитентуОПродажах.Выбрать();
    Пока ВыборкаДокументов.Следующий() Цикл
    тч = ВыборкаДокументов.Товары;
    Для каждого СтрокаТЧ Из тч Цикл
    СтрокаТЧ.ДатаПродажи = СтрокаТЧ.ДокументПродажи.Дата;
    КонецЦикла;
    ТекДок = ВыборкаДокументов.ПолучитьОбъект();
    ТекДок.Записать();
    КонецЦикла;
    КонецПроцедуры
    Пишет " Поле объекта недоступно для записи (ДатаПродажи) СтрокаТЧ.ДатаПродажи = СтрокаТЧ.ДокументПродажи.Дата".
    Помогите, пожалуйста, разобраться, в чем ошибка.
  2. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Может так получится?
    Код:
    Процедура КнопкаВыполнитьНажатие(Элемент)
    ВыборкаДокументов = Документы.ОтчетКомитентуОПродажах.Выбрать();
    Пока ВыборкаДокументов.Следующий() Цикл
    ТекДок = ВыборкаДокументов.ПолучитьОбъект();
    тч = ТекДок.Товары;
    Для каждого СтрокаТЧ Из тч Цикл
    СтрокаТЧ.ДатаПродажи = СтрокаТЧ.ДокументПродажи.Дата;
    КонецЦикла;
    ТекДок.Записать();
    КонецЦикла;
    КонецПроцедуры
    
    P.S. Работоспособность не проверял.
  3. TopicStarter Overlay
    tumanovalex
    Offline

    tumanovalex

    Регистрация:
    3 июл 2006
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Спасибо большое, получилось

Поделиться этой страницей