7.7 Почему не выводится список

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем tmpnikl, 6 мар 2013.

  1. TopicStarter Overlay
    tmpnikl
    Offline

    tmpnikl Опытный в 1С

    Регистрация:
    28 ноя 2012
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Написал обработку...
    Код:
    С = СоздатьОбъект("Справочник.Сотр");
    С.ВыбратьЭлементы();
    Пока С.ПолучитьЭлемент() = 1  Цикл
    СТЭ = С.ТекущийЭлемент();
    Если СТЭ.ПометкаУдаления() = 1 Тогда
    Сообщить(СТЭ.Наименование);
    Т = СоздатьОбъект("Таблица");
    Ссылки=СоздатьОбъект("ТаблицаЗначений");
    НайтиСсылки(СТЭ,Ссылки);
    Ссылки.ВыбратьСтроки();
    Пока Ссылки.ВыбратьСтроку() = 1 Цикл
    Т.ВывестиСекцию("Секция_1");
    КонецЦикла;
    Т.ТолькоПросмотр(1);
    Т.Показать(); 
    СтатусВозврата(0);
    Прервать
    КонецЕсли;
    КонецЦикла;
    СтатусВозврата(0);
    
    В самой таблице в "Секция_1" всего две ячейки
    ссылки.номерстроки и ссылки.получитьЗначение(ссылки.номерстроки,1)

    Почему то после команды Ссылки.ВыбратьСтроку() выскакивает табличка со списком документов и в таблице ничего не показывается, хотя есть два докуменьта у этого человека, где что я сделал не правильно...
  2. TopicStarter Overlay
    tmpnikl
    Offline

    tmpnikl Опытный в 1С

    Регистрация:
    28 ноя 2012
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Всё разобрался...это я переписывал с _http://www.firststeps.ru/1c/r.php?331, вместо ВыбратьСтроку надо получитьстроку()

Поделиться этой страницей