7.7 Почему не работает ВыбратьЭлемнты()?

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Реланиум, 14 янв 2010.

  1. TopicStarter Overlay
    Реланиум
    Offline

    Реланиум Опытный в 1С

    Регистрация:
    12 сен 2006
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, ну подскажите, что не так делаю.. Надо вывести в Дбфку все основные средства с длинной ВЛ больше нуля. В таком виде ДБФка пустая..
    Код:
    Процедура Выполнить()
    ДБФ=СоздатьОбъект("XBase");
    ДБФ.ДобавитьПоле("Inv",2,10,0);
    ДБФ.ДобавитьПоле("DlinaVL",1,5,);
    ДБФ.СоздатьФайл("E:\db1.dbf");
    
    Карточка=СоздатьОбъект("Справочник.ОсновныеСредства");  // присвоение объектов     
    //Карточка.порядокКодов();
    Карточка.ВыбратьЭлементы();
    Карточка.ИспользоватьДату('01.01.2008');
    //Карточка.НайтиПоКоду(12100);
    Пока Карточка.ПолучитьЭлемент()>0 Цикл 
    Код=Карточка.код;
    ДлиннаВЛ=Карточка.ДлинаВЛ;
    Если ДлиннаВЛ>0 Тогда 
    ДБФ.Добавить();
    ДБФ.Inv=Код;
    ДБФ.DlinaVL=ДлиннаВЛ;
    ДБФ.Записать();		
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    
    
    А в таком, как и ожидалась одна запись с инвентарником и длинной вл..
    Код:
    Процедура Выполнить()
    ДБФ=СоздатьОбъект("XBase");
    ДБФ.ДобавитьПоле("Inv",2,10,0);
    ДБФ.ДобавитьПоле("DlinaVL",1,5,);
    ДБФ.СоздатьФайл("E:\db1.dbf");
    
    Карточка=СоздатьОбъект("Справочник.ОсновныеСредства");  // присвоение объектов     
    //Карточка.порядокКодов();
    //Карточка.ВыбратьЭлементы();
    Карточка.ИспользоватьДату('01.01.2008');
    Карточка.НайтиПоКоду(12100);
    //Пока Карточка.ПолучитьЭлемент()>0 Цикл 
    Код=Карточка.код;
    ДлиннаВЛ=Карточка.ДлинаВЛ;
    Если ДлиннаВЛ>0 Тогда 
    ДБФ.Добавить();
    ДБФ.Inv=Код;
    ДБФ.DlinaVL=ДлиннаВЛ;
    ДБФ.Записать();		
    КонецЕсли;
    //КонецЦикла;
    КонецПроцедуры
    
    Почему не работает ВыбратьЭлемнты()???
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    Карточка.ИспользоватьДату('01.01.2008');
    Карточка.ВыбратьЭлементы();
    
    
  3. TopicStarter Overlay
    Реланиум
    Offline

    Реланиум Опытный в 1С

    Регистрация:
    12 сен 2006
    Сообщения:
    84
    Симпатии:
    0
    Баллы:
    26
    Офигеть.. а я два дня с бубном пропрыгал вокруг.. Спасибо заработало..

Поделиться этой страницей