8.х По названию месяца получить дату

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ЕкатеринаНик, 5 дек 2011.

  1. TopicStarter Overlay
    ЕкатеринаНик
    Offline

    ЕкатеринаНик Опытный в 1С

    Регистрация:
    8 ноя 2010
    Сообщения:
    698
    Симпатии:
    1
    Баллы:
    29
    Есть у меня значение "Сентябрь", как мне поставить в реквизит ДатаНач 01.09.2011?
  2. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    как-то так:

    Код:
    Функция ПолучитьНомерМесяца(ТекСлово)
    
    Если ТекСлово="Январь" Тогда
    возврат 1;
    
    // ...
    
    ИначеЕсли ТекСлово="Декабрь" Тогда
    возврат 12;
    КонецЕсли;
    
    КонецФункции
    
    
    
    
    
    
    ну а потом Дата(2011,ПолучитьНомерМесяца(ТекСлово),1) использовать..
  3. TopicStarter Overlay
    ЕкатеринаНик
    Offline

    ЕкатеринаНик Опытный в 1С

    Регистрация:
    8 ноя 2010
    Сообщения:
    698
    Симпатии:
    1
    Баллы:
    29
    Мое решение
    Код:
    // у меня уже есть что Месяц = "Сентябрь"
    Для Счетчик = 1 По 12 Цикл
    Представление = Формат(Дата(2000, Счетчик, 1), "ДФ='ММММ'");
    Если Месяц = Представление ТОгда      
    Сообщить(Счетчик);
    КонецЕсли;
    КонецЦикла;
    
    Спасибо за Дата(Год,Месяц,День) ))))
  4. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    ваше решение лаконичнее ;)
  5. uza
    Offline

    uza 1С, VBA (EXCEL), VB (.NET + WEB)

    Регистрация:
    10 июл 2007
    Сообщения:
    1.845
    Симпатии:
    1
    Баллы:
    29
    Красиво.
    Вот только стоит еще учитывать что на вход может прийти "Сентябрь ", "сентябрь", "СЕНТЯБРЬ" и "СеНтЯбРь"

    Но это не страшно. Лишь изменить
    Код:
    Если ВРег(СокрЛП(Месяц)) = ВРег(Представление) ТОгда
    
    
    Зато Ваше решение не зависит от региональных настроек у пользователя (когда Формат(..."ММММ") превратиться не в "Сентябрь" а в "September"
  6. TopicStarter Overlay
    ЕкатеринаНик
    Offline

    ЕкатеринаНик Опытный в 1С

    Регистрация:
    8 ноя 2010
    Сообщения:
    698
    Симпатии:
    1
    Баллы:
    29
    Нет, вряд ли мне прийдет "Сен Тябрь"))) т.к. это выгрузка данных из одной программы, там чел.фактора не будет, но ваше замечание к сведению приму.
    Решение выдрано)))) из РаботаСДиалогами ф. СписокМесяцевПоСтроке() не экпортная.
    Лучше посмотрите другую мою тему). Повернуть надо таблицу, столбцы сделать строками.
Похожие темы
  1. TODD22
    Ответов:
    12
    Просмотров:
    381
Загрузка...

Поделиться этой страницей