8.х План видов характеристик

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем evgeniy.zharkov, 14 ноя 2011.

  1. TopicStarter Overlay
    evgeniy.zharkov
    Offline

    evgeniy.zharkov

    Регистрация:
    11 окт 2011
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    Возникла задача, что бы при создании нового варианта номенклатуры название формировалось из набора свойств и значений. Сделал следующее: в форме элемента справочника ВариантыНоменклатуры добавил динамический список и прописал произвольный запрос:

    ВЫБРАТЬ
    РегистрСведенийЗначениеСвойствНоменклатуры.НаборСвойств,
    РегистрСведенийЗначениеСвойствНоменклатуры.ВидСвойств,
    РегистрСведенийЗначениеСвойствНоменклатуры.Значение
    ИЗ
    РегистрСведений.ЗначениеСвойствНоменклатуры КАК РегистрСведенийЗначениеСвойствНоменклатуры
    ГДЕ
    РегистрСведенийЗначениеСвойствНоменклатуры.НаборСвойств = &Ссылка

    В регистре сведений ЗначениеСвойствНоменклатуры написал следующее:

    Процедура ПолучитьНаименованиеСервер()
    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
    | ЗначениеСвойствНоменклатуры.ВидСвойств КАК ВидСвойств,
    | ЗначениеСвойствНоменклатуры.Значение
    |ИЗ
    | РегистрСведений.ЗначениеСвойствНоменклатуры КАК ЗначениеСвойствНоменклатуры
    |ГДЕ
    | ЗначениеСвойствНоменклатуры.НаборСвойств = &НаборСвойств
    |
    |УПОРЯДОЧИТЬ ПО
    | ВидСвойств";
    Запрос.УстановитьПараметр("НаборСвойств",Запись.НаборСвойств);
    Выборка = Запрос.Выполнить().Выбрать();
    ПолНаименование="";
    Пока Выборка.Следующий() Цикл
    ПолНаименование= ?(ПустаяСтрока(ПолНаименование),ПолНаименование,ПолНаименование+" ; ")+СокрЛП(Выборка.ВидСвойств)+": "+СокрЛП(Выборка.Значение);
    КонецЦикла;
    НС = Запись.НаборСвойств;
    НСО = НС.ПолучитьОбъект();
    НСО.Наименование=ПолНаименование;
    НСО.Записать();
    КонецПроцедуры

    &НаКлиенте
    Процедура ПослеЗаписи(ПараметрыЗаписи)
    ПолучитьНаименованиеСервер();
    Оповестить("Запись изменена");
    КонецПроцедуры

    Имя ВариантаНоменклатуры изменяется, но при добавлении нового свойства ВариантНоменклатуры не определяется и поэтому я не могу добавить свойство и значение. Подскажите что нужно ещё дописать
  2. gosn1ck
    Offline

    gosn1ck Опытный в 1С

    Регистрация:
    13 авг 2009
    Сообщения:
    1.329
    Симпатии:
    1
    Баллы:
    26
    какая программа?
  3. TopicStarter Overlay
    evgeniy.zharkov
    Offline

    evgeniy.zharkov

    Регистрация:
    11 окт 2011
    Сообщения:
    5
    Симпатии:
    0
    Баллы:
    1
    8.2 своя конфигурация

Поделиться этой страницей