7.7 Периодические реквизиты

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Time dont wait, 23 окт 2009.

  1. TopicStarter Overlay
    Time dont wait
    Offline

    Time dont wait Опытный в 1С

    Регистрация:
    20 окт 2009
    Сообщения:
    192
    Симпатии:
    0
    Баллы:
    26
    В справочнике надо поменять данные существующие на введеные в документе КадровоеПеремещение
    Но при записи выбивает ошибка - Неверное имя реквизита!
    Все идентефикаторы сходятся , ничего не понимаю
    Код:
    СпрСотр = СоздатьОбъект("Справочник.Співробітники");
    СпрСотр.НайтиЭлемент(Співробітник);
    СпрСотр.ИспользоватьДату(ДатаПереміщення);
    
    Если СпрСотр.Категорія <> Категорія Тогда
    УстановитьРеквизитСправочника(Співробітник,"Категорія",Категорія,ДатаПереміщення);
    КонецЕсли;
    ........
    
    
    Неверное имя реквизита!
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
    СпрСотр = СоздатьОбъект("Справочник.Співробітники");	
    Если СпрСотр.НайтиЭлемент(Співробітник)=1 <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда	</span>
    Если СпрСотр.Категорія.Получить(ДатаПереміщення) <> Категорія <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда		</span>
    СпрСотр.Категорія.Установить(ДатаПереміщення,Категорія);
    КонецЕсли;
    КонецЕсли;
    
    

Поделиться этой страницей