7.7 Периодические реквизиты в запросе

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем ЧКДзержинский, 1 авг 2007.

  1. TopicStarter Overlay
    ЧКДзержинский
    Offline

    ЧКДзержинский Опытный в 1С

    Регистрация:
    7 дек 2006
    Сообщения:
    487
    Симпатии:
    3
    Баллы:
    29
    Есть такая задача: нужно запросить элемены справочника со значениями периодических реквизитов, установленных в определенном периоде. Например, я формирую запрос за период июль месяц 2007 года. Если для элемента справочника установлено значение периодического реквизита июльской датой, то это значение должно попасть в результат запроса, а если значение записано допустим в июне, а позже ничего нового не записывалось, то в данном случае в запрос ничего не должно попасть.
  2. TopicStarter Overlay
    ЧКДзержинский
    Offline

    ЧКДзержинский Опытный в 1С

    Регистрация:
    7 дек 2006
    Сообщения:
    487
    Симпатии:
    3
    Баллы:
    29
    Все, разобрался :unsure:
  3. Snake-84
    Offline

    Snake-84 Опытный в 1С

    Регистрация:
    28 янв 2007
    Сообщения:
    110
    Симпатии:
    0
    Баллы:
    26
    Если не сложно, покажи как, а то самому такое скоро предстоит
  4. TopicStarter Overlay
    ЧКДзержинский
    Offline

    ЧКДзержинский Опытный в 1С

    Регистрация:
    7 дек 2006
    Сообщения:
    487
    Симпатии:
    3
    Баллы:
    29
    Создаешь внешнюю функцию для проверки даты ввода значения периодического реквизита, вот моя:

    Функция Актуальность(Элемент)
    ОП = СоздатьОбъект("Периодический");
    ОП.ИспользоватьОбъект("ПланПродаж", Элемент);
    ОП.ВыбратьЗначения();
    Пока ОП.ПолучитьЗначение() = 1 Цикл
    //ДатаНачала - дата начала отчета.
    //В моем случае может быть только одна запись за месяц
    Если НачМесяца(ОП.ДатаЗнач) = НачМесяца(ДатаНачала) Тогда
    Возврат 1;
    КонецЕсли;
    КонецЦикла;
    Возврат 0;
    КонецФункции

    В запросе создаешь дополнительное условие

    |ТекЭлемент = Справочник.ПланДляКонтрагента.ТекущийЭлемент;
    |Условие (Актуальность(ТекЭлемент) = 1);

Поделиться этой страницей