8.х ЗУП Период отпуска

Тема в разделе ""1С:Зарплата и управление персоналом ЗУП"", создана пользователем dlis, 19 мар 2013.

  1. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    Как определить дату окончания отпуска имея дату начала и продолжительность календарных дней?? Пока на уме только одно:
    запросом выбрать из производственного календаря количество праздничных дней, к дате начала прибавить количество дней и количество праздничных. Может есть способ лучше??
  2. svet
    Offline

    svet Профессионал в 1С Команда форума

    Регистрация:
    9 ноя 2007
    Сообщения:
    1.971
    Симпатии:
    59
    Баллы:
    54
    А куда еще лучше-то? :)
    В стандартной, насколько я помню, именно так и делается. Кстати, а чем вам стандартная не подходит?
  3. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    не нашел стандартную ) подскажите где?
  4. svet
    Offline

    svet Профессионал в 1С Команда форума

    Регистрация:
    9 ноя 2007
    Сообщения:
    1.971
    Симпатии:
    59
    Баллы:
    54
    В кадровом документе "Отпуска организаций" при вводе дат начала и окончания отпуска рассчитывается количество дней. При исправлении дат программа предлагает изменить количество дней - там и пересчитывается.

    А сама процедура вызывается из общего модуля ЗаполнениеДокументовЗК, процедура КоличествоДнейОтпускаПоКалендарнымДням.

    А-а-а... Там не праздники вычитаются, там по регламентированному календарю сразу берутся КалендарныеДни.
  5. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    Так я хочу сделать так, чтобы вводилось количество дней отпуска, а дата окончания сама проставлялась
  6. svet
    Offline

    svet Профессионал в 1С Команда форума

    Регистрация:
    9 ноя 2007
    Сообщения:
    1.971
    Симпатии:
    59
    Баллы:
    54
    Так документ "Отпуска организаций" именно так и работает. :) Вводите поля не по порядку, а так: дата начала, количество дней - и программа сама посчитает дату окончания.
  7. svet
    Offline

    svet Профессионал в 1С Команда форума

    Регистрация:
    9 ноя 2007
    Сообщения:
    1.971
    Симпатии:
    59
    Баллы:
    54
    Есть у вас в РБ процедура-то? Вот на всякий случай:

    Код:
    Функция КоличествоДнейОтпускаПоКалендарнымДням(ДатаНачала, ДатаОкончания, ВключатьПраздники = Ложь)
    
    Если НЕ ВключатьПраздники Тогда
    Запрос = Новый Запрос(
    "ВЫБРАТЬ
    | СУММА(РегламентированныйПроизводственныйКалендарь.КалендарныеДни) КАК КоличествоДней
    |ИЗ
    | РегистрСведений.РегламентированныйПроизводственныйКалендарь КАК РегламентированныйПроизводственныйКалендарь
    |ГДЕ
    | РегламентированныйПроизводственныйКалендарь.ДатаКалендаря >= &ДатаНачала
    | И РегламентированныйПроизводственныйКалендарь.ДатаКалендаря <= &ДатаОкончания");
    
    Запрос.УстановитьПараметр("ДатаНачала", ДатаНачала);
    Запрос.УстановитьПараметр("ДатаОкончания", ДатаОкончания);
    
    Выборка = Запрос.Выполнить().Выбрать();
    Если Выборка.Следующий() Тогда
    КоличествоДней = Выборка.КоличествоДней;
    Иначе
    ОбщегоНазначения.СообщитьОбОшибке("Проверьте заполнение производственного календаря!");
    КоличествоДней = Неопределено;
    КонецЕсли;
    Иначе
    КоличествоДней = (НачалоДня(ДатаОкончания) - НачалоДня(ДатаНачала)) / 86400 + 1;
    КонецЕсли;
    
    Возврат КоличествоДней;
    
    КонецФункции // КоличествоДнейОтпускаПоКалендарнымДням
    
  8. TopicStarter Overlay
    dlis
    Offline

    dlis Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    266
    Симпатии:
    0
    Баллы:
    26
    все есть, только в форме не так работает, чтобы дата окончания стала автоматическе нужно вводить сначала количество дней, а потом только дату начала, если ввеси наоборот, то дата окончания не установиться ((
  9. svet
    Offline

    svet Профессионал в 1С Команда форума

    Регистрация:
    9 ноя 2007
    Сообщения:
    1.971
    Симпатии:
    59
    Баллы:
    54
    :( Не повезло. У меня УПП, вроде как работает в любом направлении.
Похожие темы
  1. OksM
    Ответов:
    0
    Просмотров:
    1.919
  2. Delf17
    Ответов:
    4
    Просмотров:
    690
  3. VidaSony
    Ответов:
    14
    Просмотров:
    3.511
  4. punkyklan
    Ответов:
    3
    Просмотров:
    847
  5. sveto4ek_u2
    Ответов:
    1
    Просмотров:
    175
Загрузка...

Поделиться этой страницей