7.7 Перезаполнение ТЧ документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Alex_Staf, 6 май 2012.

  1. TopicStarter Overlay
    Alex_Staf
    Offline

    Alex_Staf

    Регистрация:
    8 мар 2010
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Добрый день, в 7.7 я новичок.
    Сделал:
    Есть документ Счет по кнопке "Договор" формируется документ Договор - шаблон типового договора + На основании содержимого ТЧ документа Счет формируется перечень поставляемого товара в том же документе Договор.
    В документе Счет добавлен реквизит - ссылка на созданный документ Договор.
    Необходимо сделать возможность перзаполнения ТЧ документа Договор на основании ТЧ документа Счет.
    Для этого:
    - нахожу документ Договор по имеющейся ссылке,
    - загружаю в него новую ТЧ.
    Не могу получить документ Договор, подскажите как это сделать?

    В приведенном примере вылетает ошибка "Значение не представляет агрегатный объект (ПолучитьДокумент)"

    Код:
    ОбъектДоговор = СоздатьОбъект("Документ.Договор");
    Док = ОбъектДоговор.НайтиДокумент(БланкДоговора);
    Док.ПолучитьДокумент();
  2. SerzhM
    Offline

    SerzhM Опытный в 1С

    Регистрация:
    26 окт 2009
    Сообщения:
    511
    Симпатии:
    3
    Баллы:
    29
    Может этот пример поможет
    Код:
    Процедура ПриВыбореДокумента()
    Документ.УдалитьСтроки();
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку() = 1 Цикл
    Документ.НоваяСтрока();
    Документ.Товар=Док.Номенклатура;
    //  Документ.Код=Док.Номенклатура.Код;
    Документ.КолУч=Док.КоличествоУчет;
    Документ.КолФакт=Док.Количество;
    КонецЦикла;
    
    КонецПроцедуры   
  3. Бухгалтерский угодник
    Online

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Достаточно так:
    Код:
    ОбъектДоговор = СоздатьОбъект("Документ.Договор");
    ОбъектДоговор.НайтиДокумент(БланкДоговора);
    ОбъектДоговор.ВыбратьСтроки();
    Пока ОбъектДоговор.ПолучитьСтроку()=1 Цикл
    //тут выборка строк документа
    КонецЦикла;
    

Поделиться этой страницей