7.7 Переход с 7.7 на 8.3

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем sashasasha89, 2 мар 2016.

  1. TopicStarter Overlay
    sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Два раза выкидывало в конфигуратор, но Загрузка данных вроде как идёт. До этого сразу ошибка была. Или это он по ошибке остановился и замер?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    а вы по процессору в диспетчере задач посмотрите идет ли загрузка...
    Теоретически он должен остановиться на строке с ошибкой
  3. TopicStarter Overlay
    sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Ну вроде как работает.
    Первый раз остановился здесь: Обработка ПомощникПереходаСТорговлиИСклад77
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    // Пропускаем инициализацию, чтобы гарантировать получение формы при передаче параметра "АвтоТест".
    Если Параметры.Свойство("АвтоТест") Тогда
    Возврат;
    КонецЕсли;
    КонецПроцедуры
    Второй: УниверсальныйОбменДаннымиXML На строке: Возврат XMLЗначение(Тип, Значение);
    Функция одЗначениеЭлемента(Объект, Тип, ИскатьПоСвойству = "", ОбрезатьСтрокуСправа = Истина) Экспорт
    Значение = "";
    Имя = Объект.ЛокальноеИмя;
    Пока Объект.Прочитать() Цикл

    ТипУзла = Объект.ТипУзла;

    Если ТипУзла = одТипУзлаXML_Текст Тогда

    Значение = Объект.Значение;

    Если ОбрезатьСтрокуСправа Тогда

    Значение = СокрП(Значение);

    КонецЕсли;

    ИначеЕсли (Объект.ЛокальноеИмя = Имя) И (ТипУзла = одТипУзлаXML_КонецЭлемента) Тогда

    Прервать;

    Иначе

    Возврат Неопределено;

    КонецЕсли;

    КонецЦикла;

    Если (Тип = одТипСтрока)
    ИЛИ (Тип = одТипБулево)
    ИЛИ (Тип = одТипЧисло)
    ИЛИ (Тип = одТипДата)
    ИЛИ (Тип = одТипХранилищеЗначения)
    ИЛИ (Тип = одТипУникальныйИдентификатор)
    ИЛИ (Тип = одТипВидДвиженияНакопления)
    ИЛИ (Тип = одТипВидСчета)
    Тогда

    Возврат XMLЗначение(Тип, Значение);

    Иначе

    Возврат одПолучитьЗначениеПоСтроке(Значение, Тип, ИскатьПоСвойству);

    КонецЕсли;

    КонецФункции
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    возможно не смогла определить тип. Как вариант - что-то в 7ке дописывали.
    Или ссылка "битая".. Ведь наверняка ТИ БД перед выгрузкой не делали
  5. TopicStarter Overlay
    sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Сейчас если ни чего непоменяется попробую сделать ТИ и ещё раз выгружу\загружу
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    сначала посмотрите на результат загрузки
  7. TopicStarter Overlay
    sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    ТиИ сделал но при выгрузке результат 0

    Вложения:

  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Стоп... У вас же данные до этого выгружались!
  9. TopicStarter Overlay
    sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Да. Файл сохранился xml 53 мб.
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    так смотрите что именно вы после ТИ сделали не так... ТИ не может "убить" данные (при условии что база была вообще "живая")
  11. TopicStarter Overlay
    sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Незнаю как у меня выгрузилось первый раз. Но сейчас у меня не получается потому что там правила только для УТ 9.2 и 10.3. Я первый раз наверно просто выгрузил из 77 комплексной в xml.
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    у вас бы она тогда не загружалась....
    Я бы вам рекомендовал обратиться к специалисту на месте. Быстрее будит
  13. TopicStarter Overlay
    sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Буду учиться. Время есть.
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    ну тогда удачных экспериментов
  15. TopicStarter Overlay
    sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Спасибо. Будем учиться.
  16. TopicStarter Overlay
    sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Что то я ещё до конвертации недорос)) Вот попробовал перенести данные из зуп 2.5 в зик гу (так как используется БГУ) так тоже ошибка уже в конце выгрузки.

    Вложения:

  17. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    несоответствие версии правил и конфигурации скорее всего
  18. TopicStarter Overlay
    sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Последние и предпоследнии версии зуп и зик гу пробывал. Одна и та же ошибка.
    Последнее редактирование: 5 мар 2016
  19. TopicStarter Overlay
    sashasasha89
    Offline

    sashasasha89 Опытный в 1С

    Регистрация:
    20 сен 2015
    Сообщения:
    387
    Симпатии:
    0
    Баллы:
    26
    Когда развернул зик гу стартовый помощник предлогает перенести данные и версия должна быть не ниже 2.5.97. Я пробовал и 2.5.97.2 и 2.5.99.2. Все таже ошибка. Пробовал через XML но файл выгружался сутки и 500 гб. И потом место кончилось на диске.
  20. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    а база зик за сколько лет?

Поделиться этой страницей