8.х пересчитать все спецификации номенклатуры

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Cosh, 24 мар 2009.

  1. TopicStarter Overlay
    Cosh
    Offline

    Cosh

    Регистрация:
    21 июл 2008
    Сообщения:
    41
    Симпатии:
    0
    Баллы:
    1
    Платформа 8.1.13.41, Конфа УПП 1.2.19.1.

    Есть нужда пересчитать все спецификации номенклатуры. Для этого нужно домножить на коэффициент количество затрачиваемых материалов и на тот же коэффициент количество выходных изделий.

    Почти все спецификации имеют тип СБОРОЧНАЯ (есть некоторое количество с типом УЗЕЛ). С табличной частью Исходные комплектующие проблем не возникает, а вот как изменить из обработки (средствами встроенного языка) значение КОЛИЧЕСТВО, которое находится на ФормеЭлемента и сохранить его не знаю, подскажите плз как тут поступить.

    Код:
    	ВыборкаСпецификаций = Справочники.СпецификацииНоменклатуры.Выбрать();
    Пока ВыборкаСпецификаций.Следующий() Цикл
    Если Не ВыборкаСпецификаций.ПометкаУдаления Тогда
    Если Не ВыборкаСпецификаций.ЭтоГруппа Тогда
    Если ВыборкаСпецификаций.ВидСпецификации = Перечисления.ВидыСпецификаций.Сборочная Тогда
    Док = ВыборкаСпецификаций.ПолучитьОбъект();
    Форм1 = Док.ПолучитьФорму("ФормаЭлемента");
    Форм1.Количество = 5; //Для примера
    //Что нужно сделать чтоб сохранить это значение.
    Возврат;
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;	
    КонецЦикла;
    
    А вот скриншот формы документа:

    Посмотреть вложение 1723

    Гляньте плиз, и предложите способ, если не сложно, как это сделать можно, поля которые нужно домножить обвёл мелом, красным, вот. Спасибо заранее!!!

    Вложения:

    • screen.jpg
      screen.jpg
      Размер файла:
      104,6 КБ
      Просмотров:
      155
  2. GreenFox
    Offline

    GreenFox

    Регистрация:
    19 фев 2009
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    Эти значения связаны с реквизитами документа (ищи в шапке и в табличных частях) там и меняй

    Код:
    ВыборкаСпецификаций = Справочники.СпецификацииНоменклатуры.Выбрать();
    Пока ВыборкаСпецификаций.Следующий() Цикл
    Если Не ВыборкаСпецификаций.ПометкаУдаления Тогда
    Если Не ВыборкаСпецификаций.ЭтоГруппа Тогда
    Если ВыборкаСпецификаций.ВидСпецификации = Перечисления.ВидыСпецификаций.Сборочная Тогда
    Док = ВыборкаСпецификаций.ПолучитьОбъект();
    Форм1 = Док.ПолучитьФорму("ФормаЭлемента");
    Форм1.Количество = 5; //Для примера
    //Что нужно сделать чтоб сохранить это значение.
    Док.Количество = 5;
    для каждого Строка из Док.ИсходныеКомплектующие цикл// Вместо исходныеКомплектующие подставь свое название табличной части
    Строка.Количество = 5;
    КонецЦикла;
    Док.Записать(РежимЗаписиДокумента.Проведение);;
    
    КонецЕсли;
    КонецЕсли;
    КонецЕсли;	
    КонецЦикла;
    
    
Похожие темы
  1. has
    Ответов:
    0
    Просмотров:
    462
  2. mavaly
    Ответов:
    2
    Просмотров:
    594
  3. fate_kate
    Ответов:
    2
    Просмотров:
    1.013
  4. bluntschi
    Ответов:
    1
    Просмотров:
    517
  5. roofless
    Ответов:
    1
    Просмотров:
    511
Загрузка...

Поделиться этой страницей