8.х Пересчет табличной части документа построчно

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем wswolf1987, 19 фев 2019.

  1. TopicStarter Overlay
    wswolf1987
    Offline

    wswolf1987

    Регистрация:
    13 июл 2015
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Добрый день!
    Есть документ с табличной частью, в которой заполняется график платежей.
    Ткните, пожалуйста, где можно почитать или посмотреть, как организовать пересчет всей табличной части ниже строки, в которой изменяется сумма платежа?
    Не совсем понимаю как это правильно сделать: 1. пересчитать данные в текущей строке, удалить все строки ниже и снова их заполнить или 2. как то можно организовать пересчет без удаления строк.
    Прикладываю скрин для наглядности, процедура должна срабатывать при изменении значения поля ОбщаяСуммаПлатежа (пересчет остатка долга)
    321.jpg
  2. TopicStarter Overlay
    wswolf1987
    Offline

    wswolf1987

    Регистрация:
    13 июл 2015
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Сделал следующим образом:
    ТекущаяСтрока = Элементы.График1.ТекущиеДанные; // забрали строки из табличной части в переменную
    Для каждого ТекущаяСтрока Из Объект.График Цикл

    //Текст ваших пересчетов

    Сообщить("График пересчитан!");

    КонецЦикла;

    //Удаляем все ненужные строки после пересчета

    Для каждого ТекущаяСтрока Из Объект.График Цикл

    Если ТекущаяСтрока.СуммаОсновногоДолга <= 0 Тогда

    объект.График.Удалить(ТекущаяСтрока)//удаляем строки

    КонецЕсли;

    КонецЦикла;

    Не знаю по какой причине, но в одном цикле пересчет и затем удаление работать не захотело, постоянно вываливало ошибку