7.7 Пересчет суммы взаиморастетов

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем БулГахтер, 3 ноя 2008.

  1. TopicStarter Overlay
    БулГахтер
    Offline

    БулГахтер

    Регистрация:
    8 июл 2007
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Ситуация следующая: Конфигурация - Комплексная.
    Бухгалтер вводил выписки банка с указанием конкретных счетов, сейчас прошлось переделаывать на то, что бы программа автоматические выбирала счет.
    Я все это переделал, только возникла такая ситуация - сумма взаиморасчетов почему-то стерлась. Т.е. номинально она осталась, но в бухгалтерскую проводку, формируемую документом они не попадают.
    Можно как-то это исправить, т.к. документов море, и вручную просто открыть закрыть, это оооочнь долго :) А через обработку я не смог вызвать функцию перерасчета суммы взаиморасчетов
  2. Sherlock99
    Offline

    Sherlock99

    Регистрация:
    22 ноя 2007
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    Обработку на публику!
  3. TopicStarter Overlay
    БулГахтер
    Offline

    БулГахтер

    Регистрация:
    8 июл 2007
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Обработка на основе стандартной групповой обработки документов в комплексной.

    Вложения:

  4. Sherlock99
    Offline

    Sherlock99

    Регистрация:
    22 ноя 2007
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    А вызывается какая-то функция при открытии выписки, которая пересчитывает сумму взаиморасчетов?
  5. TopicStarter Overlay
    БулГахтер
    Offline

    БулГахтер

    Регистрация:
    8 июл 2007
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1

    Нет вроде бы. И мне говорили, что функции самого документа вызвать в обработке нельзя, только функции глобального модуля :(

    Если я правильно понял, то еще раз пересчет суммфы происходит при проведении документа. но странно что только если я вручную провожу, а если в обаботке пишу - провести, как буд-то этой строчки нету
  6. Sherlock99
    Offline

    Sherlock99

    Регистрация:
    22 ноя 2007
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    Скорее всего пересчет суммы запускается в документе либо при открытии, либо при изменении какого-то реквизита. Если можешь, выложи модуль документа и модуль формы документа.
  7. TopicStarter Overlay
    БулГахтер
    Offline

    БулГахтер

    Регистрация:
    8 июл 2007
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Документ называется - СтрокаВыпискиБанка

    Модуль документа

    Код:
    <pre><FONT COLOR="blue"><FONT FACE="Courier">
    
    [color=green]////////////////////////////////////////////////////////////////////////////////[/color]
    [color=green]// ОПИСАНИЕ МОДУЛЬНЫХ ПЕРЕМЕННЫХ[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> СписокДействий[color=red];[/color] [color=green]// для механизма кнопки "Действия"[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> НачальнаяДатаДокумента[color=red];[/color] [color=green]// для механизма контроля уникальности номеров[/color]
    
    [color=green]// Для контроля необходимости пересчетов[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> СтараяДата[color=red],[/color] СтараяФирма[color=red],[/color] СтараяВалюта[color=red],[/color] СтарыйКурс[color=red],[/color] СтараяКратность[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> СтарыйДоговор[color=red],[/color] СтарыйКонтрагент[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">Перем</span> ТекущийДолг[color=red];[/color]
    
    [color=green]////////////////////////////////////////////////////////////////////////////////[/color]
    [color=green]// ПРОЦЕДУРЫ И ФУНКЦИИ МОДУЛЯ     [/color]
    [color=green]//*****************************************************************************[/color]
    [color=green]// ТекстВалюты(Вал)[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  Вал - элемент справочника "Валюты"[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение: [/color]
    [color=green]//  Строка валюты[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]// 	Возвращает название валюты или строку "<нет валюты>"[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/функция')">Функция</span> ТекстВалюты[color=red]([/color]Вал[color=red])[/color] 
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">	Возврат</span> [color=red]?[/color][color=red]([/color]ПустоеЗначение[color=red]([/color]Вал[color=red])[/color][color=red]=[/color][color=black]0[/color][color=red],[/color]Вал[color=red].[/color]Наименование[color=red],[/color][color=black]"<нет>"[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецфункции')">КонецФункции</span>  [color=green]// ТекстВалюты()[/color]
    
    [color=green]//*****************************************************************************[/color]
    [color=green]// ЗаголовокФормы()[/color]
    [color=green]//[/color]
    [color=green]// Параметры: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение: [/color]
    [color=green]//  Название операции[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]// 	Формирует название операции и заголовок формы диалога[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/функция')">Функция</span> ЗаголовокФормы[color=red]([/color][color=red])[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> Заголовок[color=red],[/color] Название[color=red];[/color]
    
    Заголовок 	[color=red]=[/color] глНазваниеДокументаВЖурнале[color=red]([/color]Контекст[color=red])[/color][color=red];[/color]
    Название 	[color=red]=[/color] Заголовок[color=red]+[/color][color=black]" №"[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Выбран[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>  
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Проведен[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Заголовок [color=red]=[/color] Заголовок [color=red]+[/color] [color=black]". Проведен"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    Заголовок [color=red]=[/color] Заголовок [color=red]+[/color] [color=black]". Не проведен"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    Заголовок [color=red]=[/color] Заголовок [color=red]+[/color] [color=black]". Новый"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    Форма[color=red].[/color]Заголовок[color=red]([/color]Заголовок[color=red])[/color][color=red];[/color]               
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">	Возврат</span> Название[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецфункции')">КонецФункции</span> [color=green]//ЗаголовокФормы                                                   [/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// УправлениеВидимостью()[/color]
    [color=green]//[/color]
    [color=green]// Параметры:[/color]
    [color=green]//	Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Управляет видимостью реквизитов в зависимости от кода операции.[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> УправлениеВидимостью[color=red]([/color][color=red])[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> КодОперации [color=red]<[/color][color=red]>[/color] Перечисление[color=red].[/color]КодыОпераций[color=red].[/color]Прочее <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color=red].[/color]ИспользоватьЗакладки[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    Форма[color=red].[/color]ИспользоватьСлой[color=red]([/color][color=black]"Общий1, Общий2, Взаиморасчеты"[/color][color=red],[/color] [color=black]2[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    Форма[color=red].[/color]ИспользоватьЗакладки[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    [color=green]// Закладка "Общее".[/color]
    Форма[color=red].[/color]Закладки[color=red].[/color]Установить[color=red]([/color][color=black]"Общее"[/color][color=red],[/color]			[color=black]"Общий1, Общий2, Прочее"[/color][color=red])[/color][color=red];[/color]
    [color=green]// Закладка "Налоговый учет".[/color]
    Форма[color=red].[/color]Закладки[color=red].[/color]Установить[color=red]([/color][color=black]"Налоговый учет"[/color][color=red],[/color]	[color=black]"Общий1, Общий2, ПрочееНУ"[/color][color=red])[/color][color=red];[/color]
    
    [color=green]// Установка текущей закладки - при открытии формы.[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Форма[color=red].[/color]Закладки[color=red].[/color]ТекущаяСтрока[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color=red].[/color]Закладки[color=red].[/color]ТекущаяСтрока[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    Форма[color=red].[/color]ИспользоватьСлой[color=red]([/color]Форма[color=red].[/color]Закладки[color=red].[/color]ПолучитьЗначение[color=red]([/color]Форма[color=red].[/color]Закладки[color=red].[/color]ТекущаяСтрока[color=red]([/color][color=red])[/color][color=red])[/color][color=red],[/color] [color=black]2[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span>  [color=green]// УправлениеВидимостью()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// УправлениеДоступностью()[/color]
    [color=green]//[/color]
    [color=green]// Параметры:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет.[/color]
    [color=green]//[/color]
    [color=green]// Вызывается из формул элементов диалога:[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Управляет доступностью элементов диалога.[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> УправлениеДоступностью[color=red]([/color][color=red])[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> Форма[color=red].[/color]ТолькоПросмотр[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Договор[color=red].[/color]ВалютаВзаиморасчетов [color=red]=[/color] Валюта <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color=red].[/color]кнСуммаВзаиморасчетов[color=red].[/color]Доступность[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    Форма[color=red].[/color]кнСуммаВзаиморасчетов[color=red].[/color]Доступность[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Валюта [color=red]=[/color] глРубли <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color=red].[/color]Курс[color=red].[/color]Доступность[color=red]([/color][color=black]0[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    Форма[color=red].[/color]Курс[color=red].[/color]Доступность[color=red]([/color][color=black]1[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// УправлениеДоступностью()[/color]
    
    [color=green]//******************************************************************************        [/color]
    [color=green]// ПриВыбореСубконто(ИдРеквизита, НомерРеквизита)[/color]
    [color=green]// [/color]
    [color=green]// Параметры: [/color]
    [color=green]//  ИдРеквизита - общая часть идентификатора реквизитов (например "Субконто" или[/color]
    [color=green]// 				  "СубконтоНУ")[/color]
    [color=green]//  НомерРеквизита - Порядковый номер в названии реквизита[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение: [/color]
    [color=green]//  Нет [/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]// 	При изменении значения в реквизитах "Субконто" или "СубконтоНУ", проверяет[/color]
    [color=green]//  не являются ли типы последующих реквизитов подчиненными справочниками. Если [/color]
    [color=green]//  являются, то в случае несоответствия между владельцем и подчиненным элементом[/color]
    [color=green]//  значение подчиненного элемента очищается.[/color]
    [color=green]//  (Например Контрагент - Договор)[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПриВыбореСубконто[color=red]([/color]ИдРеквизита[color=red],[/color] НомерРеквизита[color=red])[/color]
    
    СубкВлад [color=red]=[/color] ПолучитьАтрибут[color=red]([/color]ИдРеквизита[color=red]+[/color]НомерРеквизита[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ТипЗначенияСтр[color=red]([/color]СубкВлад[color=red])[/color] [color=red]=[/color] [color=black]"Справочник"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/для')">		Для</span> т [color=red]=[/color] НомерРеквизита [color=red]+[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/по')">По</span> [color=black]3[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    СубкПодч [color=red]=[/color] ПолучитьАтрибут[color=red]([/color]ИдРеквизита[color=red]+[/color]т[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">			Если</span> ТипЗначенияСтр[color=red]([/color]СубкПодч[color=red])[/color] [color=red]=[/color] [color=black]"Справочник"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">				Если</span> [color=red]([/color]СубкПодч[color=red].[/color]Выбран[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color][color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span> [color=red]([/color]ТипЗначенияСтр[color=red]([/color]СубкПодч[color=red].[/color]Владелец[color=red])[/color] [color=red]=[/color] [color=black]"Справочник"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">					Если</span> СубкПодч[color=red].[/color]Владелец[color=red].[/color]Вид[color=red]([/color][color=red])[/color] [color=red]=[/color] СубкВлад[color=red].[/color]Вид[color=red]([/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">						Если</span> [color=red]([/color]СубкПодч[color=red].[/color]Владелец[color=red].[/color]Выбран[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]0[/color][color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">или</span> [color=red]([/color]СубкПодч[color=red].[/color]Владелец [color=red]<[/color][color=red]>[/color] СубкВлад[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    УстановитьАтрибут[color=red]([/color]ИдРеквизита[color=red]+[/color]т[color=red],[/color] [color=black]""[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">						КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">					КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">				КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">			КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">		КонецЦикла</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПриВыбореСубконто()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ЗаполнитьСписокВидовОплаты()[/color]
    [color=green]//[/color]
    [color=green]// Параметры:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Вызывается из формул элементов диалога:[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Заполняет представленный в диалоге список видов оплат всеми возможными значениями.[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ЗаполнитьСписокВидовОплаты[color=red]([/color][color=red])[/color]
    
    СписокВидовОплаты[color=red].[/color]ДобавитьЗначение[color=red]([/color]глКО[color=red].[/color]ОплатаПоставщику[color=red])[/color][color=red];[/color]
    СписокВидовОплаты[color=red].[/color]ДобавитьЗначение[color=red]([/color]глКО[color=red].[/color]ВозвратОплатыПокупателю[color=red])[/color][color=red];[/color]
    СписокВидовОплаты[color=red].[/color]ДобавитьЗначение[color=red]([/color]глКО[color=red].[/color]Прочее[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ЗаполнитьСписокВидовОплаты()[/color]
    
    [color=green]//******************************************************************************        [/color]
    [color=green]// ПересчетСуммыВзаиморасчетов()[/color]
    [color=green]// [/color]
    [color=green]// Параметры: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение: [/color]
    [color=green]//  Нет [/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]// 	Пересчитывает сумму в валюте взаиморасчетов.[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПересчетСуммыВзаиморасчетов[color=red]([/color][color=red])[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ПустоеЗначение[color=red]([/color]Договор[color=red].[/color]ВалютаВзаиморасчетов[color=red])[/color] [color=red]=[/color][color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СуммаВзаиморасчетов	[color=red]=[/color] [color=black]0[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    СуммаВзаиморасчетов [color=red]=[/color] глПересчет[color=red]([/color]Сумма[color=red],[/color]
    Валюта[color=red],[/color]Курс[color=red],[/color]
    Договор[color=red].[/color]ВалютаВзаиморасчетов[color=red],[/color]ДатаДок[color=red],[/color]Кратность[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    Форма[color=red].[/color]Обновить[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПересчетСуммыВзаиморасчетов()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// РасчетТекущегоДолга()[/color]
    [color=green]//[/color]
    [color=green]// Параметры:[/color]
    [color=green]//	Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//	Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание: [/color]
    [color=green]//	Производит вызов глобальной функции расчета суммы текущего долга контрагента.[/color]
    [color=green]//  В зависимости от характера задолженности устанавливает [/color]
    [color=green]//  цвет элемента диалога "Сумма долга". (Если долг >= 0 - синий, иначе - красный)   [/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> РасчетТекущегоДолга[color=red]([/color][color=red])[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span>  [color=red]([/color]КодОперации [color=red]=[/color] глКО[color=red].[/color]ВозвратОплатыПокупателю[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    [color=green]// расход - возврат покупателю[/color]
    ТекущийДолг [color=red]=[/color] глТекущийДолг[color=red]([/color]Фирма[color=red],[/color] Договор[color=red],[/color] [color=black]"Покупатель"[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> [color=red]([/color]КодОперации [color=red]=[/color] глКО[color=red].[/color]ОплатаПоставщику[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    [color=green]// расход - оплата поставщику[/color]
    ТекущийДолг [color=red]=[/color] глТекущийДолг[color=red]([/color]Фирма[color=red],[/color] Договор[color=red],[/color] [color=black]"Поставщик"[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    ТекущийДолг [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    Форма[color=red].[/color]ТекстТекущийДолг[color=red].[/color]Заголовок[color=red]([/color]глФРМ[color=red]([/color]ТекущийДолг[color=red],[/color]Договор[color=red].[/color]ВалютаВзаиморасчетов[color=red])[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ТекущийДолг [color=red]<[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Форма[color=red].[/color]ТекстТекущийДолг[color=red].[/color]Цвет[color=red]([/color][color=black]255[/color][color=red])[/color][color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    Форма[color=red].[/color]ТекстТекущийДолг[color=red].[/color]Цвет[color=red]([/color][color=black]0[/color][color=red],[/color][color=black]0[/color][color=red],[/color][color=black]128[/color][color=red])[/color][color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]//РасчетТекущегоДолга()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ЗаполнениеПоДокументуОснованию()[/color]
    [color=green]//[/color]
    [color=green]// Параметры:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Вызывается из формул элементов диалога:[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Производит заполнение документа по документу  - основанию.[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/функция')">Функция</span> ЗаполнениеПоДокументуОснованию[color=red]([/color][color=red])[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ДокОснование[color=red].[/color]Выбран[color=red]([/color][color=red])[/color][color=red]=[/color][color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span> [color=black]"Не выбран документ - основание"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]  
    
    ВидОсн [color=red]=[/color] ДокОснование[color=red].[/color]Вид[color=red]([/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> [color=red]([/color]ВидОсн [color=red]<[/color][color=red]>[/color] [color=black]"ВозвратОтПокупателя"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span>
    [color=red]([/color]ВидОсн [color=red]<[/color][color=red]>[/color] [color=black]"ЗаказПоставщику"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span>
    [color=red]([/color]ВидОсн [color=red]<[/color][color=red]>[/color] [color=black]"ОтчетКомитенту"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span>
    [color=red]([/color]ВидОсн [color=red]<[/color][color=red]>[/color] [color=black]"ПоступлениеДопРасходы"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span>
    [color=red]([/color]ВидОсн [color=red]<[/color][color=red]>[/color] [color=black]"ПоступлениеТМЦ"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span>
    [color=red]([/color]ВидОсн [color=red]<[/color][color=red]>[/color] [color=black]"ПоступлениеТМЦИмпорт"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span>
    [color=red]([/color]ВидОсн [color=red]<[/color][color=red]>[/color] [color=black]"ПоступлениеТМЦРозница"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span>
    [color=red]([/color]ВидОсн [color=red]<[/color][color=red]>[/color] [color=black]"ПоступлениеПрочее"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span>
    [color=red]([/color]ВидОсн [color=red]<[/color][color=red]>[/color] [color=black]"ПлатежноеПоручение"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/и')">и</span>
    [color=red]([/color]ВидОсн [color=red]<[/color][color=red]>[/color] [color=black]"СтрокаВыпискиПриход"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span> [color=black]"Неверный вид документа - основания!"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    СуммаОсн [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> [color=red]([/color]ВидОсн [color=red]=[/color] [color=black]"СтрокаВыпискиПриход"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ВалютаОсн    [color=red]=[/color] ДокОснование[color=red].[/color]Валюта[color=red];[/color]
    КурсОсн      [color=red]=[/color] ДокОснование[color=red].[/color]Курс[color=red];[/color]
    КратностьОсн [color=red]=[/color] ДокОснование[color=red].[/color]Кратность[color=red];[/color]
    СуммаОсн     [color=red]=[/color] ДокОснование[color=red].[/color]Сумма[color=red];[/color]
    ОблагаетсяНП [color=red]=[/color] ДокОснование[color=red].[/color]ОблагаетсяНП[color=red];[/color]
    СуммаВзаиморасчетов [color=red]=[/color] ДокОснование[color=red].[/color]СуммаВзаиморасчетов[color=red];[/color]
    Сумма        [color=red]=[/color] глПересчет[color=red]([/color]СуммаОсн[color=red],[/color] ВалютаОсн[color=red],[/color] КурсОсн[color=red],[/color] Валюта[color=red],[/color] Курс[color=red],[/color] КратностьОсн[color=red],[/color] Кратность[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> [color=red]([/color]ВидОсн [color=red]=[/color] [color=black]"ВозвратОтПокупателя"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ВалютаОсн    [color=red]=[/color] ДокОснование[color=red].[/color]Валюта[color=red];[/color]
    КурсОсн      [color=red]=[/color] ДокОснование[color=red].[/color]Курс[color=red];[/color]
    КратностьОсн [color=red]=[/color] ДокОснование[color=red].[/color]Кратность[color=red];[/color]
    ОблагаетсяНП [color=red]=[/color] ДокОснование[color=red].[/color]УчитыватьНП[color=red];[/color]
    СуммаОсн     [color=red]=[/color] ДокОснование[color=red].[/color]Итог[color=red]([/color][color=black]"Сумма"[/color][color=red])[/color] [color=red]+[/color]
    [color=red]?[/color][color=red]([/color]ДокОснование[color=red].[/color]СуммаВклНП  [color=red]=[/color] [color=black]1[/color][color=red],[/color] [color=black]0[/color][color=red],[/color] ДокОснование[color=red].[/color]Итог[color=red]([/color][color=black]"СуммаНП"[/color][color=red])[/color][color=red])[/color] [color=red]+[/color]
    [color=red]?[/color][color=red]([/color]ДокОснование[color=red].[/color]СуммаВклНДС [color=red]=[/color] [color=black]1[/color][color=red],[/color] [color=black]0[/color][color=red],[/color] ДокОснование[color=red].[/color]Итог[color=red]([/color][color=black]"СуммаНДС"[/color][color=red])[/color][color=red])[/color][color=red];[/color]
    СуммаВзаиморасчетов [color=red]=[/color] ДокОснование[color=red].[/color]СуммаВзаиморасчетов[color=red];[/color]
    Сумма        [color=red]=[/color] глПересчет[color=red]([/color]СуммаОсн[color=red],[/color] ВалютаОсн[color=red],[/color] КурсОсн[color=red],[/color] Валюта[color=red],[/color] Курс[color=red],[/color] КратностьОсн[color=red],[/color] Кратность[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> [color=red]([/color]ВидОсн [color=red]=[/color] [color=black]"ПлатежноеПоручение"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ВалютаОсн    [color=red]=[/color] глРубли[color=red];[/color]
    КурсОсн      [color=red]=[/color] глКурсДляВалюты[color=red]([/color]глРубли[color=red],[/color] ДатаДок[color=red])[/color][color=red];[/color]
    КратностьОсн [color=red]=[/color] глКратностьДляВалюты[color=red]([/color]глРубли[color=red],[/color] ДатаДок[color=red])[/color][color=red];[/color]
    СуммаОсн     [color=red]=[/color] ДокОснование[color=red].[/color]Сумма[color=red];[/color]
    Сумма        [color=red]=[/color] глПересчет[color=red]([/color]СуммаОсн[color=red],[/color] ВалютаОсн[color=red],[/color] КурсОсн[color=red],[/color] Валюта[color=red],[/color] Курс[color=red],[/color] КратностьОсн[color=red],[/color] Кратность[color=red])[/color][color=red];[/color]
    ПересчетСуммыВзаиморасчетов[color=red]([/color][color=red])[/color][color=red];[/color]      
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> [color=red]([/color]ВидОсн [color=red]=[/color] [color=black]"ОтчетКомитенту"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ВалютаОсн 	 [color=red]=[/color] ДокОснование[color=red].[/color]Договор[color=red].[/color]ВалютаВзаиморасчетов[color=red];[/color]
    КурсОсн      [color=red]=[/color] ДокОснование[color=red].[/color]Курс[color=red];[/color]
    КратностьОсн [color=red]=[/color] ДокОснование[color=red].[/color]Кратность[color=red];[/color]
    
    РегПоставщики [color=red]=[/color] СоздатьОбъект[color=red]([/color][color=black]"Регистр.Поставщики"[/color][color=red])[/color][color=red];[/color]
    РегПоставщики[color=red].[/color]ВыбратьДвиженияДокумента[color=red]([/color]ДокОснование[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/пока')">		Пока</span> РегПоставщики[color=red].[/color]ПолучитьДвижение[color=red]([/color][color=red])[/color] [color=red]=[/color] [color=black]1[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/цикл')">Цикл</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">Если</span> РегПоставщики[color=red].[/color]КодОперации [color=red]=[/color] глКО[color=red].[/color]ОтчетКомитенту <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    СуммаОсн [color=red]=[/color] СуммаОсн [color=red]+[/color]  РегПоставщики[color=red].[/color]СуммаВал[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">КонецЕсли</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конеццикла')">		КонецЦикла</span>[color=red];[/color]                                            
    
    СуммаВзаиморасчетов [color=red]=[/color] СуммаОсн[color=red];[/color]
    Сумма [color=red]=[/color] глПересчет[color=red]([/color]СуммаОсн[color=red],[/color] ВалютаОсн[color=red],[/color] КурсОсн[color=red],[/color] Валюта[color=red],[/color] Курс[color=red],[/color] КратностьОсн[color=red],[/color] Кратность[color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> [color=red]([/color]ВидОсн [color=red]=[/color] [color=black]"ПоступлениеТМЦИмпорт"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ОблагаетсяНП        [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    [color=green]// Оплачиваем по умолчанию сумму, которую считаем нужным оплатить по взаиморасчетам[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> СуммаВзаиморасчетов [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Сумма [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    Сумма [color=red]=[/color] глПересчет[color=red]([/color]СуммаВзаиморасчетов[color=red],[/color] Договор[color=red].[/color]ВалютаВзаиморасчетов[color=red],[/color] ДатаДок[color=red],[/color] Валюта[color=red],[/color] Курс[color=red],[/color][color=red],[/color] Кратность[color=red])[/color][color=red];[/color]  
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color] 
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    СуммаВзаиморасчетов [color=red]=[/color] ДокОснование[color=red].[/color]СуммаВзаиморасчетов[color=red];[/color]
    ОблагаетсяНП        [color=red]=[/color] ДокОснование[color=red].[/color]УчитыватьНП[color=red];[/color]
    [color=green]// Оплачиваем по умолчанию сумму, которую считаем нужным оплатить по взаиморасчетам[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> СуммаВзаиморасчетов [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Сумма [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">		Иначе</span>
    Сумма [color=red]=[/color] глПересчет[color=red]([/color]СуммаВзаиморасчетов[color=red],[/color] Договор[color=red].[/color]ВалютаВзаиморасчетов[color=red],[/color] ДатаДок[color=red],[/color] Валюта[color=red],[/color] Курс[color=red],[/color][color=red],[/color] Кратность[color=red])[/color][color=red];[/color]  
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color] 
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> [color=red]([/color]ВидОсн [color=red]=[/color] [color=black]"ВозвратОтПокупателя"[/color][color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/или')">или</span> [color=red]([/color]ВидОсн [color=red]=[/color] [color=black]"СтрокаВыпискиПриход"[/color][color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    КодОперации [color=red]=[/color] глКО[color=red].[/color]ВозвратОплатыПокупателю[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначе')">	Иначе</span>
    КодОперации [color=red]=[/color] глКО[color=red].[/color]ОплатаПоставщику[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    СтараяВалюта [color=red]=[/color] Валюта[color=red];[/color] 
    СтарыйКурс   [color=red]=[/color] Курс[color=red];[/color]
    СтараяКратность [color=red]=[/color] Кратность[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">	Возврат</span> [color=black]""[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецфункции')">КонецФункции</span> [color=green]// ЗаполнениеПоДокументуОснованию()[/color]
    
    [color=green]//*****************************************************************************[/color]
    [color=green]// ПоКнопкеОснование()[/color]
    [color=green]// [/color]
    [color=green]// Параметры: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение: [/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]// 	Вызывается по кнопке выбора документа основания                  [/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПоКнопкеОснование[color=red]([/color][color=red])[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/перем')">	Перем</span> Основание[color=red];[/color]
    
    [color=green]// если документ основание уже есть, откроем его[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ПустоеЗначение[color=red]([/color]ДокОснование[color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ОткрытьФорму[color=red]([/color]ДокОснование[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">		Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    [color=green]// если документа - основания нет, позволяем выбрать его[/color]
    Основание [color=red]=[/color] глВыбратьОснование[color=red]([/color]Контекст[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span> ПустоеЗначение[color=red]([/color]Основание[color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    [color=green]// Выбрали основание[/color]
    глЗаполнитьШапкуНаОсн[color=red]([/color]Контекст[color=red],[/color]Основание[color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ПустоеЗначение[color=red]([/color]БанковскийСчет[color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    Валюта [color=red]=[/color] БанковскийСчет[color=red].[/color]ВалютаСчета[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    
    ТекстВопроса [color=red]=[/color] [color=black]"Заполнить сумму по документу основанию?"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Сумма [color=red]<[/color][color=red]>[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    ТекстВопроса [color=red]=[/color] ТекстВопроса [color=red]+[/color] РазделительСтрок [color=red]+[/color][color=black]"(перед заполнением сумма будет обнулена)"[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> Вопрос[color=red]([/color]ТекстВопроса[color=red],[/color] [color=black]"Да+Нет"[/color][color=red],[/color] [color=black]60[/color][color=red])[/color] [color=red]<[/color][color=red]>[/color] [color=black]"Да"[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/возврат')">			Возврат</span>[color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    Сумма [color=red]=[/color] [color=black]0[/color][color=red];[/color]
    Результат [color=red]=[/color] ЗаполнениеПоДокументуОснованию[color=red]([/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">		Если</span> ПустоеЗначение[color=red]([/color]Результат[color=red])[/color] [color=red]=[/color] [color=black]0[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/предупреждение')">			Предупреждение</span>[color=red]([/color]Результат[color=red],[/color] [color=black]60[/color][color=red])[/color][color=red];[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">		КонецЕсли</span>[color=red];[/color]
    
    СтарыйКонтрагент	[color=red]=[/color] Контрагент[color=red];[/color]
    СтарыйДоговор		[color=red]=[/color] Договор[color=red];[/color]
    
    РасчетТекущегоДолга[color=red]([/color][color=red])[/color][color=red];[/color]           
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]//ПоКнопкеОснование()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ПоКнопкеДолгКлиента()[/color]
    [color=green]//[/color]
    [color=green]// Параметры:[/color]
    [color=green]//  [/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Вызывается из формул элементов диалога:[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/процедура')">Процедура</span> ПоКнопкеДолгКлиента[color=red]([/color][color=red])[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/если')">	Если</span>      [color=red]([/color]КодОперации [color=red]=[/color] глКО[color=red].[/color]ВозвратОплатыПокупателю[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    [color=green]// расход - возврат покупателю[/color]
    глВзаиморасчеты[color=red]([/color]Фирма[color=red],[/color]Договор[color=red],[/color][color=black]"Покупатель"[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/иначеесли')">	ИначеЕсли</span> [color=red]([/color]КодОперации [color=red]=[/color] глКО[color=red].[/color]ОплатаПоставщику[color=red])[/color] <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/тогда')">Тогда</span>
    [color=green]//  расход - оплата поставщику[/color]
    глВзаиморасчеты[color=red]([/color]Фирма[color=red],[/color]Договор[color=red],[/color][color=black]"Поставщик"[/color][color=red])[/color][color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецесли')">	КонецЕсли</span>[color=red];[/color]
    
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/конецпроцедуры')">КонецПроцедуры</span> [color=green]// ПоКнопкеДолгКлиента()[/color]
    
    [color=green]//******************************************************************************[/color]
    [color=green]// ПриИзмененииВидаОплаты()[/color]
    [color=green]//[/color]
    [color=green]// Параметры:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Возвращаемое значение:[/color]
    [color=green]//  Нет[/color]
    [color=green]//[/color]
    [color=green]// Вызывается из формул элементов диалога:[/color]
    [color=green]//  Вид оплаты.[/color]
    [color=green]//[/color]
    [color=green]// Описание:[/color]
    [color=green]//  Производит все необходимые пересчеты при изменении вида оплаты.[/color]
    [color=green]//[/color]
    <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.
  8. Sherlock99
    Offline

    Sherlock99

    Регистрация:
    22 ноя 2007
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    Посмотри эту обработку

    Вложения:

    • Банк_.ert
      Размер файла:
      12,5 КБ
      Просмотров:
      53
  9. TopicStarter Overlay
    БулГахтер
    Offline

    БулГахтер

    Регистрация:
    8 июл 2007
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Спасибо огромное, очень выручил
Похожие темы
  1. Макароля
    Ответов:
    1
    Просмотров:
    620
  2. kibergoevs
    Ответов:
    21
    Просмотров:
    2.715
Загрузка...

Поделиться этой страницей