8.х Пересчет цен в документе (Фиксация цен)

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем daab, 23 окт 2014.

  1. TopicStarter Overlay
    daab
    Offline

    daab Опытный в 1С

    Регистрация:
    14 окт 2011
    Сообщения:
    269
    Симпатии:
    0
    Баллы:
    26
    Доброго времени суток друзья!
    Конфа 8.3 БП 3.0
    Вопрос такой
    В 7.7 Бухгалтерии была реализована функция в документе РасходнаяНакладная, которая, в ходе установки некой наценки, при необходимости возвращала исходную цену (цену себестоимости). При анализе кода документа я обнаружил в его модуле следующее:
    Код:
        Если (КодВидаОтгрузки<=2) и (ЗафиксироватьЦены=0) Тогда
                    //расчет цены
                    ВыбратьСтроки();
                    Пока ПолучитьСтроку()=1 Цикл
                        Если Товар<>ТаблицаДокумента.Товар Тогда
                            Продолжить;
                        КонецЕсли;
                       
                        Если КоличествоНаСкладах=0 Тогда
                            Сообщить(""+Товар+": нулевое количество. Расчет наценки невозможен!");
                        Иначе
                            Цена    = СуммаНаСкладах/КоличествоНаСкладах*(1+Наценка/100);
                            Сумма    = Цена*Количество;
                            НДС        = глПоказательДокумента(Контекст, "НДС");
                            Всего    = глПоказательДокумента(Контекст, "СуммаСНалогами");
                        КонецЕсли;
                    КонецЦикла;
                КонецЕсли;
    Я понял, что здесь играют роль БухИтоги.
    В 8ке, как я понял, за БухИтоги отвечает РегистрБухгалтерии.Хозрасчетный.
    Проблема в том что этот регистр никак не отображен в модуле документа.
    Куда копать и в можно ли это реализовать например в форме Товары?
  2. TopicStarter Overlay
    daab
    Offline

    daab Опытный в 1С

    Регистрация:
    14 окт 2011
    Сообщения:
    269
    Симпатии:
    0
    Баллы:
    26
    Реанимация темы!

    Ребят в общем как изменить цены в документе на среднюю цену по остаткам

    Пишу запрос на получения остатков. Далее как передать данные в документ, где бы произошел отбор по имеющимся позициям и произошла замена цен?

Поделиться этой страницей