7.7 Перерасчет

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Time dont wait, 26 ноя 2009.

  1. TopicStarter Overlay
    Time dont wait
    Offline

    Time dont wait Опытный в 1С

    Регистрация:
    20 окт 2009
    Сообщения:
    192
    Симпатии:
    0
    Баллы:
    26
    Есть процедура , которая расчиывает ПД при нажатии на кнопку, но в случае перерасчета ПД, после нажатия происходит расчет от тех чисел которые уже были расчитаны, и сумма добавляется , а не перерасчитывается:
    Код:
    Процедура ВычислитьПД()
    
    Если ВН<=940   тогда
    ПД = (ВН-ПФ-СоцСтр-ФЗ-302.5)*0.15;
    КонецЕсли; 
    
    Если ВН>940 тогда
    ПД = (ВН-ПФ-СоцСтр-ФЗ)*0.15;
    КонецЕсли;
    
    КонецПроцедуры
    
    
    Как сделать правильный перерасчет
  2. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    Не понятно что такое ПД, но не суть. Наверное это должна быть не процедура а функция. Или ПД должна быть общей переменной. Или это все реквизиты формы?
    Совет такой, пользуйтесь отладчиком, ну или хотя бы делайте Message() в нужных местах.
    P.S. если процедура вызывается много раз, лучше сделать одно условие, а не два как у вас в коде.
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Как вариант - используй не реквизиты а локальные переменные

Поделиться этой страницей