8.х Переписать код с 7-ного на 8-шный

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Korovay, 21 фев 2011.

  1. TopicStarter Overlay
    Korovay
    Offline

    Korovay Опытный в 1С

    Регистрация:
    3 авг 2009
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Хочу перенести шаблон проводок из ЗиК в ЗиУП с помощью COMОбъекта.
    В начале написал обработку в ЗиК, затем пишу обработку в ЗиУП и вставляю туда код из ЗиК.
    При реализации данного момента возникает вопрос, чем заменить ПустоеЗначение из 7-ки?
    Код:
    	Подразделение = v7.CreateObject("Справочник.Подразделения");
    Подразделение.ВыбратьЭлементы();
    Пока Подразделение.ПолучитьЭлемент()=1 Цикл
    ТекПодразделение = Подразделение.ТекущийЭлемент();
    Если ТекПодразделение.ПометкаУдаления() = 0 Тогда
    Если  ПустоеЗначение(ТекПодразделение.ШаблонПроводки) = 0 Тогда
    ПометкаУд =  ТекПодразделение.ПометкаУдаления();
    ГруппаПдр = ТекПодразделение.ЭтоГруппа();
    ПоискШаблонПдр = ТекПодразделение.Наименование;
    КодПодр = ТекПодразделение.Код;
    СчетДтПдр = ТекПодразделение.ШаблонПроводки.СчетДебета.Код;
    СчетКтПдр = ТекПодразделение.ШаблонПроводки.СчетКредита.Код;
    Если  ПустоеЗначение(ТекПодразделение.ШаблонПроводки.Субконто1Дебета) = 0  Тогда
    Субконто1Дебета = ТекПодразделение.ШаблонПроводки.Субконто1Дебета.Наименование;	
    КонецЕсли;
    Субконто1Кредита = ТекПодразделение.ШаблонПроводки.Субконто1Кредита.Наименование;	
    КонецЕсли;
    Если ПустоеЗначение(ТекПодразделение.ШаблонПроводки.Субконто2Кредита) = 0 Тогда
    Субконто2Кредита = ТекПодразделение.ШаблонПроводки.Субконто2Кредита.Наименование;	
    КонецЕсли;
    ......
    ......
    КонецЕсли; 
    КонецЕсли; 	
    КонецЦикла;    
    
  2. has
    Offline

    has Опытный в 1С

    Регистрация:
    18 июн 2009
    Сообщения:
    708
    Симпатии:
    0
    Баллы:
    26
    Код:
    Если НЕ ЗначениеЗаполнено(ТекПодразделение.ШаблонПроводки.Субконто1Дебета) Тогда
    

Поделиться этой страницей