8.х Переписать из семерки в восьмерку

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем autoexec, 8 янв 2009.

  1. TopicStarter Overlay
    autoexec
    Offline

    autoexec

    Регистрация:
    8 янв 2009
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    С наступившем всех новым годом!!!



    Помогите пожалуйста переписать процедуру из 7-ки в 8.1


    Код:
    Процедура Ремонт()
    ДокРем = СоздатьОбъект("Документ");
    Если ДокРем.ВыбратьПодчиненныеДокументы(,,текущийдокумент())=1 тогда
    пока ДокРем.ПолучитьДокумент()=1 цикл 
    если ДокРем.Вид()="Ремонт" тогда
    ВыдачаСуществует=1;прервать;  
    иначе ВыдачаСуществует=0 
    КонецЕсли;      
    КонецЦикла;
    если ВыдачаСуществует=1 тогда
    открытьформу(ДокРем.ТекущийДокумент(),,);  
    иначе открытьформу("Документ.Ремонт",контекст,ТекущийДокумент());              
    КонецЕсли;
    иначе 
    открытьформу("Документ.Ремонт",контекст,ТекущийДокумент());
    КонецЕсли;
    КонецПроцедуры
    
    

    Заранее спасибо!
  2. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Лучше в книжке посмотрите.

    1.
    Код:
    ДокРем = СоздатьОбъект("Документ");
    
    -->
    Код:
    ДокРем = Документы.ВИДВАШЕГОДОКУМЕНТА.СоздатьДокумент();
    
    2. Подчиненные документы я выбираю запросом, делаю выборку документов с условием на дкоумент основание, но тут зависит от вашей структуры данных.

    3. Форму перед открытием надо получить, вроде так:
    Код:
    ФормаДок = ДокРем.Ссылка.ПолучитьФорму(...);
    ФормаДок.Открыть();
    
    Целиком я вам код тут не перепишу, вам придется самостоятельно в отладчике все проверить и доработать. У меня не хватает данных для переписывания.

Поделиться этой страницей