7.7 Перенос?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Almius, 16 май 2007.

  1. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Подскажите плиз..........
    Задача: Необходимо каталожные номера из документа записать в справочник. как это реализовать.

    Поправте меня.
    Процедура ПереносКатНомеров ()
    Док = СоздатьОбъект("Документ.РозходТМЦ");
    Мат = СоздатьОбъект("Справочник.Материалы");
    КатНом = СоздатьОбъект("Справочник.КаталогНомер");
    Док.ВыбратьДокументы(НачГода(РабочаяДата()),'31.12.07') ;

    Пока Док.ПолучитьДокумент()=1 Цикл
    Док.ВыбратьСтроки();

    Сообщить(""+Док);

    Пока Док.ПолучитьСтроку()=1 Цикл
    КатНом.Новый();
    КатНом.Наименование=Док.НомНоменкл;
    КатНом.Записать();
    КонецЦикла;
    КонецЦикла;
    КонецПроцедуры
  2. alex-79
    Offline

    alex-79 Опытный в 1С

    Регистрация:
    21 сен 2006
    Сообщения:
    643
    Симпатии:
    1
    Баллы:
    29
    Так ведь весь алгоритм у тебя уже описан :unsure:
  3. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Не все так просто....
    вот что она пишет

    Розход ТМЦ (Списание ТМЦ) 1
    КатНом.Записать();
    EXTFORMS\1.ERT(15)}: Не выбран элемент справочника-хозяина! Элемент не может быть записан!
  4. Amishechka
    Offline

    Amishechka Опытный в 1С

    Регистрация:
    8 сен 2006
    Сообщения:
    361
    Симпатии:
    1
    Баллы:
    26
    Наверно у тебя справочник "КаталогНомер" подчинен справочнику "Материалы". Поэтому надо так (вроде):
    Док.ВыбратьДокументы(НачГода(РабочаяДата()),'31.12.07') ;
    Пока Док.ПолучитьДокумент()=1 Цикл
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку()=1 Цикл
    КатНом.ИспользоватьВладельца(Док.Материал);
    КатНом.Новый();
    КатНом.Наименование=Док.НомНоменкл;
    КатНом.Записать();
    КонецЦикла;
    КонецЦикла;
  5. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Спасибки все точно. не подскажешь как сделать что бы не писала те номера
    которые уже есть в справочнике?
  6. ЧКДзержинский
    Offline

    ЧКДзержинский Опытный в 1С

    Регистрация:
    7 дек 2006
    Сообщения:
    487
    Симпатии:
    3
    Баллы:
    29
    Док.ВыбратьДокументы(НачГода(РабочаяДата()),'31.12.07') ;
    Пока Док.ПолучитьДокумент()=1 Цикл
    Док.ВыбратьСтроки();
    Пока Док.ПолучитьСтроку()=1 Цикл
    КатНом.ИспользоватьВладельца(Док.Материал);
    Если КатНом.НайтиПоНаименованию(Док.НомНоменкл,1)=1 Тогда
    Сообщить("Номер уже существует "+Док.НомНоменкл);
    Продолжить;
    КонецЕсли;
    КатНом.Новый();
    КатНом.Наименование=Док.НомНоменкл;
    КатНом.Записать();
    КонецЦикла;
    КонецЦикла;
  7. TopicStarter Overlay
    Almius
    Offline

    Almius

    Регистрация:
    4 май 2007
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Спасибо выручили

Поделиться этой страницей