8.х Перенос текста по строкам в макет печати

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Drakonchegg, 24 мар 2012.

  1. TopicStarter Overlay
    Drakonchegg
    Offline

    Drakonchegg Опытный в 1С

    Регистрация:
    17 мар 2012
    Сообщения:
    117
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, подскажите в макете печати есть примеру 4 строки. В одном строке <Параметр> текст большой, как сделать
    что бы они перенеслись на следующий строку?
    _____________________ <Параметр>
    _____________________Строка1
    _____________________Строка2
    _____________________Строка3
  2. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    В свойствах ячейки параметр РазмещениеТекста установить в Переносить.
  3. TopicStarter Overlay
    Drakonchegg
    Offline

    Drakonchegg Опытный в 1С

    Регистрация:
    17 мар 2012
    Сообщения:
    117
    Симпатии:
    0
    Баллы:
    26
    Делал, не получается(
  4. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    А что не получается? Текст не переносится? Высота строки установлена в Авто?
  5. TopicStarter Overlay
    Drakonchegg
    Offline

    Drakonchegg Опытный в 1С

    Регистрация:
    17 мар 2012
    Сообщения:
    117
    Симпатии:
    0
    Баллы:
    26

    Вложения:

    • 1.png
      1.png
      Размер файла:
      10,8 КБ
      Просмотров:
      302
    • 2.png
      2.png
      Размер файла:
      7,8 КБ
      Просмотров:
      321
  6. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Тогда в коде, при выводе, делите строку и выводите её в разные строки макета. Соответственно в макете нужно три параметра (для каждой подстроки свой).
    В общих чертах, как-то так.
  7. TopicStarter Overlay
    Drakonchegg
    Offline

    Drakonchegg Опытный в 1С

    Регистрация:
    17 мар 2012
    Сообщения:
    117
    Симпатии:
    0
    Баллы:
    26
    Можно пример? Дальше разберусь)
  8. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    а объединить нужные строки с 46-48 в макете не поможет?
  9. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    формируйте строку с помощью Символы.ПС:


    Код:
    ТекСтрока = "хорошо живет на свете винни пух"+Символы.ПС+
    "оттого поет он эти песни вслух";
  10. Колесо
    Offline

    Колесо Опытный в 1С

    Регистрация:
    7 янв 2012
    Сообщения:
    69
    Симпатии:
    0
    Баллы:
    26
    Вот так, например, я разбивал паспортные данные.
    Код:
    ДлинаСтрокиДокумента=СтрДлина(ВыборкаШапки.Документ);
    Если ДлинаСтрокиДокумента>95 Тогда
    ПослПробел=ПоследнийПробел(ВыборкаШапки.Документ);
    ОбластьМакета.Параметры.Документ= Лев(ВыборкаШапки.Документ,ПослПробел);
    ОбластьМакета.Параметры.Документ1=Прав(ВыборкаШапки.Документ,ДлинаСтрокиДокумента-ПослПробел);
    Иначе
    ОбластьМакета.Параметры.Документ= ВыборкаШапки.Документ;
    КонецЕсли;
    Функция ПоследнийПробел(стр) Экспорт
    пробел=" ";
    ПозицияПробела=0;
    Для инд=1 по 95 цикл
    символ=сред(стр,инд,1);
    Если символ=пробел Тогда
    ПозицияПробела=инд;
    КонецЕсли	  ;
    КонецЦикла;
    Возврат ПозицияПробела;
    КонецФункции
    
  11. Svet42
    Offline

    Svet42 Опытный в 1С

    Регистрация:
    19 окт 2013
    Сообщения:
    200
    Симпатии:
    1
    Баллы:
    29
    Тоже столкнулась с переносом, если кто сталкивался подскажите, Создала ВПФ договор. Вообщем есть параметр запас(в него выводиться полное наименование номенклатуры). И так как номенклатура имеет длинное наименование, необходимо чтобы оно переносилось на другую строку. Ни как не могу въехать как это сделать. Пробывала задать свойство ячейке переносить, но совсем не то что хотелось бы видеть. Прилагаю скрин макета.

    Вложения:

  12. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    сделайте ячейку 1 во всю строку и укажате ШАБЛОН вместо текст или параметр. Далее поместите в нее вот такой текст "1.1 Заказчик (тут лальше ваш текст из строки [Запас]". Ну и заполните параметры области в коде как обычно. В свойствах ячейки укажите Переносить
  13. Svet42
    Offline

    Svet42 Опытный в 1С

    Регистрация:
    19 окт 2013
    Сообщения:
    200
    Симпатии:
    1
    Баллы:
    29
    Пар = УправлениеНебольшойФирмойСервер.ПолучитьПредставлениеНоменклатурыДляПечати(ВыборкаСтрокЗапасы.Запас, );

    ОбластьМакета.Параметры.Запас= "1.1. ЗАКАЗЧИК поручает, а ИСПОЛНИТЕЛЬ принимает на себя обязательство провести " + Пар;
    все выводит просто супер, че то сразу не догадалась. Но все равно спасибо за помощь))
  14. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    ну вы просто все в параметр загнали, можно было и шаблоном сделать, но это как удобнее, главное работает и правильно
  15. Svet42
    Offline

    Svet42 Опытный в 1С

    Регистрация:
    19 окт 2013
    Сообщения:
    200
    Симпатии:
    1
    Баллы:
    29
    Да я вашу идею поняла, но мне так удобнее. Все равно вам огромное спасибо, что уделяете время таким бестолочам как я)
  16. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    самокритично вы, но все же учатся, так что задавайте вопросы, тольок о правилах ыорума не забывайте и все будет отлично
Похожие темы
  1. Xpavel86
    Ответов:
    1
    Просмотров:
    1.365
  2. dfx
    Ответов:
    2
    Просмотров:
    530
Загрузка...

Поделиться этой страницей