7.7 перенос таблицы

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Artur999, 15 авг 2012.

  1. TopicStarter Overlay
    Artur999
    Offline

    Artur999

    Регистрация:
    15 авг 2012
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Добрый день, столкнулся с такой проблемой есть отчет в длину он не помешается на один лист и печатается на двух. Подскажите как перенести на другую строчку таблицу которая не поместилась вот что я смог сделать но так и не работает . Подскажите что здесь неправильно.Разбиваю по ширине по 6 колонок. но все равно выводит в одну строчку


    Код:
    Перем ИТОГД,ИтогК,ИТОГДК,ИтогКК;
    Процедура Сформировать_Колонки(Ит, Таб, Стр)
    Таб.ВывестиСекцию(Стр+"|Начало");
    Ит.ВыбратьКорСчета(1, 1);
    Пока Ит.ПолучитьКорСчет() = 1 Цикл
    Таб.ПрисоединитьСекцию(Стр+"|КорСчет_Дт");
    КонецЦикла;
    Таб.ПрисоединитьСекцию(Стр+"|Оборот_Дт");
    Ит.ВыбратьКорСчета(1, 2);
    Пока Ит.ПолучитьКорСчет() = 1 Цикл
    Таб.ПрисоединитьСекцию(Стр+"|КорСчет_Кт");
    КонецЦикла;
    Таб.ПрисоединитьСекцию(Стр+"|Оборот_Кт");
    Таб.ПрисоединитьСекцию(Стр+"|Конец");
    КонецПроцедуры
    Процедура Сформировать()
    Итог=0;
    ИтогД=0;
    Итог1=0;
    ИтогК=0;
    Итог2=0;
    ИтогДК=0;
    Итог3=0;
    ИтогКК=0;
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ВключатьСубсчета(1, 0);
    Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, "68",,, 3,, "С");
    Таб.ВывестиСекцию("Заголовок");
    Сформировать_Колонки(Ит, Таб, "Шапка");
    Таб.Опции(0,0,Таб.ШиринаТаблицы(),,,,,1);
    Ит.ВыбратьСчета();
    КолСТ=Таб.ШиринаТаблицы();
    Если КолСТ>=6 Тогда
    КолСТ=0;
    Таб.НоваяСтрока();
    Пока Ит.ПолучитьСчет() = 1 Цикл
    Если (Ит.Счет<>СчетПоКоду("68"))  Тогда
    Сформировать_Колонки(Ит, Таб, "Счет");
    Итог=Ит.СНД();
    Итог1=Ит.СНК();
    Итог2=Ит.СКД();
    Итог3=Ит.СКК();
    // Если (Ит.Счет<>СчетПоКоду("68.6")) Тогда
    ИтогД=ИтогД+Итог;
    ИтогК=ИтогК+Итог1;
    ИтогДК=ИтогДК+Итог2;
    ИтогКК=ИтогКК+Итог3;
    КонецЕсли;
    //  КонецЕсли;
    КонецЦикла;
    //КонецЕсли;
    Сформировать_Колонки(Ит, Таб, "Подвал");
    ИтогД=ИтогД+Итог;
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать","");
    КонецПроцедуры
    //}}БУХГАЛТЕРСКИЙ ЗАПРОС
    
    Процедура ПриОткрытии()
    КонецПроцедуры
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    у вас условие вне цикла+ Вместо НоваяСтрока - ВывестиСекцию используйте

Поделиться этой страницей