8.х Перенос остатков из 7,7 в 8,1 СОМСоединение

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем kible, 15 окт 2010.

  1. TopicStarter Overlay
    kible
    Offline

    kible Опытный в 1С

    Регистрация:
    14 апр 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Задача. Перенести остатки по счету из 7,7 в регистр накопления 8,1

    Подключаюсь к базе делаю запрос по счету. Выбираю остатки. Не знаю как из загрузить в 8,1.

    НовДокумент = Документы.ВыдачаСпецОдежды.СоздатьДокумент();

    Дата2 = ТекущаяДата();
    Дата1 = НачалоМесяца(ТекущаяДата());
    ПутьКИБ="E:\УНГГ НПС";
    База = Новый COMОбъект("v77.Application");
    Открыта = База.Initialize(База.RMTrade,"/D""" + ПутьКИБ + """ /M ","NO_SPLASH_SHOW");


    БИ = База.CreateObject("БухгалтерскиеИтоги");
    Сотрудник = База.ВидыСубконто.Сотрудники;
    СпецОдежда = База.ВидыСубконто.СпецОдежда;
    с="";
    БИ.ИспользоватьСубконто(Сотрудник,с,1);
    БИ.ИспользоватьСубконто(СпецОдежда,с,1);
    БИ.ВыполнитьЗапрос(Дата1,Дата2,"ХСО");
    БИ.ВыбратьСубконто(1);
    Пока БИ.ПолучитьСубконто(1)=1 Цикл
    БИ.ВыбратьСубконто(2);
    Пока БИ.ПолучитьСубконто(2)=1 Цикл
    СпецОд=БИ.Субконто(2);
    БИ.ВыбратьСчета(1,0,1,0);
    Если БИ.ПолучитьСчет(1,"ХСО")=1 Тогда
    НовСтр = НовДокумент.ТабДокСпецОдежда.Добавить();
    НовСтр.СпецОдежда =БИ.Субконто(1);
    Сообщить(БИ.Субконто(1));
    КонецЕсли;
    КонецЦикла;
    КонецЦикла;

    НовДокумент.Дата = ТекущаяДата();
    НовДокумент.Записать();
    ФормаДок = НовДокумент.ПолучитьФорму();
    ФормаДок.Открыть();
  2. PavelBaryshev
    Offline

    PavelBaryshev Опытный в 1С

    Регистрация:
    9 сен 2008
    Сообщения:
    316
    Симпатии:
    0
    Баллы:
    26
    В восьмерке есть док "Ввод начальных остатков", там по счету, т.е. выбираешь на какой счет загрузить.
  3. TopicStarter Overlay
    kible
    Offline

    kible Опытный в 1С

    Регистрация:
    14 апр 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    регистр накопления 8,1!!!
  4. poiuy
    Offline

    poiuy Опытный в 1С

    Регистрация:
    12 окт 2010
    Сообщения:
    170
    Симпатии:
    0
    Баллы:
    26
    В какую конфигурацию пихаем?
    Просто во многих есть документ корректировка записей регистров ......
Похожие темы
  1. ganzo68
    Ответов:
    0
    Просмотров:
    1.144
  2. cukzzm
    Ответов:
    7
    Просмотров:
    790
Загрузка...

Поделиться этой страницей