7.7 Перенос контрагентов

Тема в разделе "Установка платформы "1С:Предприятие 7.7"", создана пользователем Ramzes 3, 11 фев 2010.

  1. TopicStarter Overlay
    Ramzes 3
    Offline

    Ramzes 3

    Регистрация:
    27 сен 2009
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    Люди подскажите что сделать, есть две базы, данные совершенно одинаковые, нужно сделать так чтоб из одной базы в другую скидывать контрагентов, бухгалтер в одной базе забивает контрагентов и хочет чтоб в другой они тоже отображались, выгрузку написал.... выгружается информация в текстовый документ, а вот загружаться в соседнюю базу ни в какую не хочет, помогите
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В чем выражается это "ни в какую грузиться не хочет"???
    Вылетает ошибка или что - здесь телепатов нет. Опишите ситуацию подробнее

    Совет - если не хотите поддердивать структуру папок/кодов (кстати эта одна из причин почему не грузится - не совпадают кода если вы по ним синхронизируете) - производите синхронизацию по ИНН
  3. TopicStarter Overlay
    Ramzes 3
    Offline

    Ramzes 3

    Регистрация:
    27 сен 2009
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    Я же могу в текущий справочник Контрагенты добавить загрузкой данные из другой базы?

    В модуле отчета "Загрузка контрагентов" написал следующий текст:

    Код:
    Процедура Сформировать()
    
    Спр=СоздатьОбъект("Справочник.Контрагенты");
    Текст=СоздатьОбъект("Текст");
    Список=СоздатьОбъект("СписокЗначений");
    Текст.Открыть("C:\Program Files\1Cv77\Бух\Контрагенты.txt");
    
    Для Ном=1 По Текст.КоличествоСтрок() Цикл
    Стр=Текст.ПолучитьСтроку(Ном);            
    Список.ИзСтрокиСРазделителями(Стр);
    Если Спр.НайтиПоКоду(Список.ПолучитьЗначение(1))=0 Тогда
    Спр.Новый();
    Спр.Код=Список.ПолучитьЗначение(1);
    Спр.Наименование=Список.ПолучитьЗначение(2); 
    Спр.ЛСчет=Список.ПолучитьЗначение(3);
    Спр.ПолнНаименование=Список.ПолучитьЗначение(4);
    
    КонецЕсли;
    КонецЦикла; 
    Спр.Записать();        
    Сообщить ("Готово!"); 
    КонецПроцедуры
    
    В конце пишет что "Готово!", а данные не добавляются в базу, опыта с 1с почти нету, не могу понять почему не добавляет, может неправильно модуль написан

    [warn="!!! Внимание !!!"]Пользуйтесь тегами[/warn]
  4. TopicStarter Overlay
    Ramzes 3
    Offline

    Ramzes 3

    Регистрация:
    27 сен 2009
    Сообщения:
    14
    Симпатии:
    0
    Баллы:
    1
    В общем пришлось через универсальную обработку перенести контрагентов, сам к сожалению я не смог дописать загрузку :unsure: Главное все получилось, опыта пока не хватает, все самому писать :smile:

Поделиться этой страницей