8.х КА Перенос контактной информации из комплексная 7.7 в УПП8.1

Тема в разделе ""1С:Комплексная автоматизация"", создана пользователем Julyla, 19 фев 2010.

  1. TopicStarter Overlay
    Julyla
    Offline

    Julyla

    Регистрация:
    13 янв 2010
    Сообщения:
    35
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте. Помогите пожалуйста, зашла в тупик... Необходимо перенести контактную информацию контрагентов (адреса, телевоны) из комплексной 7.7 в УПП 8.1. На диске ИТС нашла пример правила для 7.7 в 8.0, его собственно и пытаюсь подстроить под 8.1. Делала следующим образом:

    1.Создала ПКО «КонтактнаяИнформацияКонтрагенты», приемник РегистрСведенийЗапись. Контактная Информация
    2.Для него создала ПКС: «Вид», «Объект», «Тип», «Представление», поставила галочки получать из входящих данных
    3.Создала ПКС «Объект», добавила обработчик «Перед выгрузкой»
    Код:
     имяПКО = "Контрагенты"
    
    4. Создала ПВД «КонтактнаяИнформацияКонтрагенты», способ выборки «Произвольный алгоритм», правило конвертации» КонтактнаяИнформацияКонтрагенты»
    5. Добавила обработчик «Перед обработкой»
    Код:
    Таб = <span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/новый')">новый ТаблицаЗначений;</span>
    Таб.Колонки.Добавить("Объект");
    Таб.Колонки.Добавить("Вид");
    Таб.Колонки.Добавить("Тип");
    Таб.Колонки.Добавить("Представление");
    
    //контрагенты
    СпрКонтрагенты =Справочники.Контрагенты;
    
    переборСпрКонтрагенты =СпрКонтрагенты.Выбрать(,,,);
    
    Пока переборСпрКонтрагенты.Следующий() > 0  Цикл
    Если переборСпрКонтрагенты.ЭтоГруппа Тогда
    Продолжить;
    КонецЕсли;
    
    Если переборСпрКонтрагенты.юрФизЛицо = Null Тогда
    продолжить;
    КонецЕсли;
    
    Если переборСпрКонтрагенты.юрФизЛицо.ЮрАдрес <> Null и переборСпрКонтрагенты.юрФизЛицо.ЮрАдрес <> "" Тогда
    
    НоваяСтрока = Таб.Добавить();	
    НоваяСтрока.Вид = "ЮрАдресКонтрагента";
    НоваяСтрока.Тип = "Адрес";
    НоваяСтрока.Представление = переборСпрКонтрагенты.ЮрФизЛицо.ЮрАдрес; 
    НоваяСтрока.Объект = переборСпрКонтрагенты.ПолучитьОбъект();
    
    КонецЕсли;
    КонецЦикла;
    
    строки = Таб.НайтиСтроки();
    
    Для счСтрок =0 по Таб.Количество()-1 цикл       
    ВходящиеДанные = Новый Структура("Объект, Тип,Вид,Представление");
    ВходящиеДанные.Объект =Таб[счСтрок].Объект;
    ВходящиеДанные.Вид=Таб[счСтрок].Вид;
    ВходящиеДанные.Представление=Таб[счСтрок].Представление;
    ВходящиеДанные.Тип=Таб[счСтрок].Тип;
    ВыгрузитьПоПравилу(,, ВходящиеДанные,, "КонтактнаяИнформацияОрганизаций");
    КонецЦикла;
    
    
    
    В результате в РегистрСведений Контактная Информация добавляется информация по первому найденному контрагенту, а адрес берется последнего найденного… В чем может быть проблема?
  2. gosn1ck
    Offline

    gosn1ck Опытный в 1С

    Регистрация:
    13 авг 2009
    Сообщения:
    1.329
    Симпатии:
    1
    Баллы:
    26
    а не проще было бы сделать отчет в 7ке по всем данным, которые надо выгрузить и сохранить его в excel, а затем загрузить из excel куда хотите :unsure:
  3. TopicStarter Overlay
    Julyla
    Offline

    Julyla

    Регистрация:
    13 янв 2010
    Сообщения:
    35
    Симпатии:
    0
    Баллы:
    1
    А через конвертацию как сделать?

Поделиться этой страницей