7.7 Перенос данных из текстового файла

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем ДмитрийF, 21 сен 2006.

  1. TopicStarter Overlay
    ДмитрийF
    Offline

    ДмитрийF

    Регистрация:
    19 сен 2006
    Сообщения:
    47
    Симпатии:
    0
    Баллы:
    1
    Как перенести из текстового файла в Зарплату и кадры данные по работникам.
    Может программа какая есть? А то решили платить матпомощь неработающим пенсионерам, естественно надо отчитываться по подоходному налогу. А их 800 человек, причем они есть в старой кадровой программе и там можно данные экспортировать в текстовый файл. Конечно, я понимаю, что все данные должны быть форматированными под конкретную программу, чтоб она не искала с какой позиции строки что брать. Это не проблема. На VB могу подогнать, а вот язык 1С еще не знаю. Если есть хоть что-нибудь, дайте ссылку, все же что-нибудь соображу.
  2. Pilgrim
    Offline

    Pilgrim Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    242
    Симпатии:
    0
    Баллы:
    26
    Если есть буха, то посмотри какую-нибудь обработку по загрузке из клиент-банка, если нету,
    то напиши, куда скинуть, кину какую-нибудь для примеру (прикрепить не получилось).
  3. Tiger
    Offline

    Tiger Опытный в 1С

    Регистрация:
    12 июл 2006
    Сообщения:
    489
    Симпатии:
    0
    Баллы:
    26
    Вот пример работы с текстовыми файлами
    Код:
    ТекстДок = СоздатьОбъект("Текст");
    ТекстДок.Открыть("catalog.txt");
    ТекстДок.ЗаменитьСтроку(52, "Установка оборудования......" + Стоимость);
    ТекстДок.ВставитьСтроку(53, "Замена оборудования... ");
    ТекстДок.УдалитьСтроку(10);
    ТекстДок.ДобавитьСтроку("Конец файла");
    
    ТекстДок2 = СоздатьОбъект("Текст");
    ТекстДок2.Шаблон(1);
    
    Для н = 1 По ТекстДок.КоличествоСтрок(1) Цикл
    ..........стр = ТекстДок.ПолучитьСтроку(н);
    ..........стр2 = "[н]" + стр;
    .........ТекстДок2.ДобавитьСтроку(стр2);
    КонецЦикла;
    
    ТекстДок2.Записать("catalog2.txt");
    ТекстДок2.ТолькоПросмотр(1);
    ТекстДок2.Показать();
    
    Более подробно здесь http://www.mista.ru/tutor_1c/text.htm
  4. TopicStarter Overlay
    ДмитрийF
    Offline

    ДмитрийF

    Регистрация:
    19 сен 2006
    Сообщения:
    47
    Симпатии:
    0
    Баллы:
    1
    Спасибо. Но конечно хочется готовый внешний модуль для переноса Фамилии, Имени, Отчества, паспортных данных, ИНН, даты рождения чтобы не придумывать велосипед.
  5. Pilgrim
    Offline

    Pilgrim Опытный в 1С

    Регистрация:
    13 сен 2006
    Сообщения:
    242
    Симпатии:
    0
    Баллы:
    26
    ТЗ = СоздатьОбъект("ТаблицаЗначений");
    ТЗ.НоваяКолонка("Фимилия");
    ТЗ.НоваяКолонка("Имя");
    ТЗ.НоваяКолонка("Отчество");

    ТекстФайла = СоздатьОбъект("Текст");
    ТекстФайла.Открыть(ИмяФайла);

    СтрНом = 1;
    Пока СтрНом <= ТекстФайла.КоличествоСтрок() Цикл
    ТЗ.НоваяСтрока();
    СЗ.ИзСтрокиСРазделителями(ТекстФайла.ПолучитьСтроку(СтрНом));
    ТЗ.Заполнить(СЗ,СтрНом-1);
    СтрНом = СтрНом + 1;
    КонецЦикла;

    СпрСотрудники = СоздатьОбъект("Справочник.Сотрудники");
    Пока ТЗ.ПолучитьСтроку() = 1 Цикл
    СпрСотрудники.Новый();
    СпрСотрудники.Фамилия = ТЗ.Фамилия;
    СпрСотрудники.Имя= ТЗ.Имя;
    СпрСотрудники.Отчество= ТЗ.Отчество;
    СпрСотрудники.Записать();
    КонецЦикла;

    Реквизиты сам поправишь только под свои.

Поделиться этой страницей