8.х ОБМЕН Перенос данных через OLE в 8.1

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем korse, 6 мар 2009.

  1. TopicStarter Overlay
    korse
    Offline

    korse

    Регистрация:
    13 янв 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Помогите разобраться с OLE! Необходимо перенести данные документа "ОтражениеЗарплатыВРеглУчете" из ЗУП В Бух8 через OLE. Проблема с определением типа реквизита, например, "СубконтоДт1. Данный реквизит может содержать перечисление или справочник. Вопрос в следующем: 1. Как определить тип значения? 2. Если это перечисление, то как узнать какое и его значение, если справочник, то какой? 3. Если пункты1,2 разрешены, то каким образом в базе-приемнике найти соответствуйщий элемент справочника, если тип элемента из базы-источника переменный,т.е. как обратиться к менеджеру справочника, когда название типа храниться в переменной, полученной из источника: Справочники.???.НайтиПоКоду(...)?
    Пример кода:
    Код:
    Запрос=ЗУП.NewObject("Запрос");
    Запрос.Текст="ВЫБРАТЬ
    |	ОтражениеЗарплатыВРеглУчете.Ссылка
    |ИЗ
    |	Документ.ОтражениеЗарплатыВРеглУчете КАК ОтражениеЗарплатыВРеглУчете
    |ГДЕ
    |	ОтражениеЗарплатыВРеглУчете.Проведен = ИСТИНА
    |	И ОтражениеЗарплатыВРеглУчете.Дата МЕЖДУ &НачалоМесяца И &КонецМесяца";
    Запрос.УстановитьПараметр("НачалоМесяца",НачалоМесяца(ДатаВыгрузки));			 
    Запрос.УстановитьПараметр("КонецМесяца",КонецМесяца(ДатаВыгрузки));
    Результат=Запрос.Выполнить();
    Если Результат.Пустой() Тогда
    Предупреждение("Нет данных за указанный период!",10);
    Возврат;
    КонецЕсли;	
    Выборка=Результат.Выбрать();
    Пока Выборка.Следующий() Цикл
    Сообщить(Выборка.Ссылка.Номер);
    ТЗ1=Выборка.Ссылка.ОтражениеВУчете.Выгрузить();
    ТЧ=Выборка.Ссылка.ОтражениеВУчете;
    Для Каждого Стр ИЗ ТЗ1 Цикл
    Стр.СубконтоДт1 - КАК  С ЭТИМ РАБОТАТЬ???
    КонецЦикла;
    //...
    КонецЦикла;
    
  2. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    А чем не устраивает обмен через xml?
    С перечислениями по оле геморройно работать.
  3. TopicStarter Overlay
    korse
    Offline

    korse

    Регистрация:
    13 янв 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Хотелось бы все-таки знать как с OLE работать. В литературе ничего стоящего не написано. А с xml у меня туговато, тоже время потратить нужно на изучение
  4. LxS
    Offline

    LxS Разработчик

    Регистрация:
    5 апр 2007
    Сообщения:
    680
    Симпатии:
    0
    Баллы:
    26
    Есть поговорка: "Без труда..и рыбку из пруда.." - знаешь наверное.
    А раз решил заняться 1С, на шару тут не канает. Надо изучать.

    Для размышлений:
    Код:
    "ВЫБРАТЬ
    |    ФИОФизЛиц.Период,
    |    ФИОФизЛиц.Фамилия,
    |    ФИОФизЛиц.Имя,
    |    ФИОФизЛиц.Отчество,
    |    ВЫБОР
    |        КОГДА ФИОФизЛиц.ФизЛицо.Пол ЕСТЬ NULL 
    |            ТОГДА NULL
    |        ИНАЧЕ ВЫБОР
    |                КОГДА ФИОФизЛиц.ФизЛицо.Пол = ЗНАЧЕНИЕ(Перечисление.ПолФизическихЛиц.Мужской)
    |                    ТОГДА ""М""
    |                ИНАЧЕ ""Ж""
    |            КОНЕЦ
    |    КОНЕЦ КАК Пол
    |ИЗ
    |    РегистрСведений.ФИОФизЛиц.СрезПоследних(&Период, ) КАК ФИОФизЛиц
    |ГДЕ
    |    ФИОФизЛиц.ФизЛицо.Ссылка = &Ссылка";
    
    Этот запрос для оле. Вернуть значение перечисления, насколько я знаю, нельзя. Давно не занимался подобными вещами. XML вполне устраивает.
    И так все автоматом можно настроить через обработчик ожидания.
    
    
    
  5. TopicStarter Overlay
    korse
    Offline

    korse

    Регистрация:
    13 янв 2009
    Сообщения:
    6
    Симпатии:
    0
    Баллы:
    1
    Большое спасибо. Буду пробовать
  6. Эмин
    Offline

    Эмин Руководитель проектов

    Регистрация:
    25 май 2007
    Сообщения:
    1.178
    Симпатии:
    1
    Баллы:
    26
    Из ЗУП в БП есть типовой обмен, придумывать велосипед тут не стоит.
  7. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    а есть еще лучше чтука)) Тут гдето валяется конфа по переносу.... отлично работает.. проверял

    Вложения:

    • ОБМЕН.rar
      Размер файла:
      378,1 КБ
      Просмотров:
      338
Похожие темы
  1. agostev
    Ответов:
    6
    Просмотров:
    4.791
  2. j72001
    Ответов:
    1
    Просмотров:
    829
  3. Reader
    Ответов:
    2
    Просмотров:
    2.198
  4. var_fj54j
    Ответов:
    3
    Просмотров:
    539
  5. Golemchik
    Ответов:
    6
    Просмотров:
    1.097
Загрузка...

Поделиться этой страницей