8.х Переменая ен определена

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Sova123, 28 фев 2008.

  1. TopicStarter Overlay
    Sova123
    Offline

    Sova123

    Регистрация:
    24 фев 2008
    Сообщения:
    42
    Симпатии:
    0
    Баллы:
    1
    Создаю печатную форму:
    Код:
    Процедура ОсновныеДействияФормыПечать(Кнопка)
    // Вставить содержимое обработчика.
    Запрос = Новый Запрос;
    ТекстЗапроса = "ВЫБРАТЬ
    |    КомиссияОтПродажи.Тур,
    |    ПРЕДСТАВЛЕНИЕ(КомиссияОтПродажи.Тур),
    |    КомиссияОтПродажи.Туроператор,
    |    КомиссияОтПродажи.Стоимость,
    |    КомиссияОтПродажи.Комиссия,
    |    КомиссияОтПродажи.СуммаПеречисления как СуммаПеречисления,
    |    КомиссияПоАгенсткомуДоговору.Дата,
    |    КомиссияПоАгенсткомуДоговору.Турист,
    |    ПРЕДСТАВЛЕНИЕ(КомиссияПоАгенсткомуДоговору.Турист),
    |    КомиссияПоАгенсткомуДоговору.ДатаТура,
    |    КомиссияПоАгенсткомуДоговору.НомерСчетаТурОператора
    |ИЗ
    |    РегистрНакопления.КомиссияОтПродажи КАК КомиссияОтПродажи
    |        ЛЕВОЕ СОЕДИНЕНИЕ Документ.КомиссияПоАгенсткомуДоговору КАК КомиссияПоАгенсткомуДоговору
    |        ПО КомиссияОтПродажи.Регистратор = КомиссияПоАгенсткомуДоговору.Ссылка
    |ГДЕ
    |    КомиссияПоАгенсткомуДоговору.Туроператор = &Туроператор";
    
    Запрос.Текст = ТекстЗапроса;
    Запрос.УстановитьПараметр("Туроператор", Туроператор);
    Запрос= Запрос.Выполнить().Выгрузить();
    ТабДок = Новый ТабличныйДокумент;
    Макет = Документы.ОтчетАгента.ПолучитьМакет("Печать");
    // Заголовок
    Область = Макет.ПолучитьОбласть("Заголовок");
    Область.Параметры.Дата = Формат(Дата, "ДФ=dd.MM.yyyy");;
    ТабДок.Вывести(Область);
    // Шапка
    Область = Макет.ПолучитьОбласть("Шапка");
    //    Область.Параметры.Номер = Номер;
    Область.Параметры.Туроператор = Туроператор;
    ТабДок.Вывести(Область);
    // Турпродукт
    Область = Макет.ПолучитьОбласть("ТурпродуктШапка");
    ТабДок.Вывести(Область);
    Для Каждого ТекСтрокаТурпродукт Из Запрос Цикл
    Область = Макет.ПолучитьОбласть("Турпродукт");
    Область.Параметры.Стоимость = ТекСтрокаТурпродукт.Стоимость;
    Область.Параметры.Комиссия = ТекСтрокаТурпродукт.Комиссия;
    Область.Параметры.СуммаПеречисления = ТекСтрокаТурпродукт.СуммаПеречисления;
    Область.Параметры.Счет=ТекСтрокаТурпродукт.НомерСчетаТурОператора;
    Область.Параметры.ДатаТура=Формат(ТекСтрокаТурпродукт.ДатаТура, "ДФ=dd.MM.yyyy");
    Область.Параметры.Тур=ТекСтрокаТурпродукт.Тур;
    ТабДок.Вывести(Область);
    КонецЦикла;
    
    [b]    
    Область = Макет.ПолучитьОбласть("ИтогиСумм");
    Область.Параметры.ИтогСт = ФорматСумм(Запрос.Стоимость);
    
    ТабДок.Вывести(Область[/b]);
    
    Область = Макет.ПолучитьОбласть("Турпр");
    //    Область.Параметры.Номер = Номер;
    Область.Параметры.Туроператор = Туроператор;
    //    Область.Параметры.СуммаПеречисления = СуммаПеречисления;
    Область.Параметры.Счет=НомерСчетаТурОператора;
    Область.Параметры.Комиссия = Комиссия;
    
    ТабДок.Вывести(Область);
    
    
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.Защита = Ложь;
    ТабДок.ТолькоПросмотр = Ложь;
    ТабДок.ОтображатьЗаголовки = Ложь;
    ТабДок.Показать();
    
    КонецПроцедуры
    
    
    Область = Макет.ПолучитьОбласть("ИтогиСумм");
    Область.Параметры.ИтогСт = ФорматСумм(Запрос.Стоимость);
    ТабДок.Вывести(Область)
    При формировании печатной формы выдает такую ошибку {Документ.ОтчетАгента.Форма.ФормаДокумента(105)}: Поле объекта не обнаружено (Стоимость)
    Область.Параметры.ИтогСт = ФорматСумм(Запрос.Стоимость);
    
    
    Если писать вот так Область = Макет.ПолучитьОбласть("ИтогиСумм");
    Область.Параметры.ИтогСт = [b]ФорматСумм(Стоимость);[/b]
    ТабДок.Вывести(Область)
    
    
    Выдает такую ошибку6 {Документ.ОтчетАгента.Форма.ФормаДокумента(104,44)}: Переменная не определена (Стоимость)
    Область.Параметры.ИтогСт = ФорматСумм(<<?>>Стоимость);
    Как решить проблму?
  2. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Сделай в запросе общий итог по стоимости тогда в первой строчке выборки у тебя будет итоговая сумма стоимости а далее пойдут уже сами строки выборки. т.е.
    Код:
    
    Выборка = Запрос.Выполнить().Выбрать():
    Выборка.Следующий();
    Область.Параметры.ИтогСт = ФорматСумм(Выборка.Стоимость);
    Пока Выборка.Следующий() Цикл
    .....
    КонецЦикла;
    
    
    
  3. TopicStarter Overlay
    Sova123
    Offline

    Sova123

    Регистрация:
    24 фев 2008
    Сообщения:
    42
    Симпатии:
    0
    Баллы:
    1
    ИТОГИ ПО
    | Стоимость как ИтогСт,
    | Комиссия,
    | СуммаПеречисления";

    вот так? А как тепеь итог присвоить СуммаСт?)) :unsure:
  4. AlexFF
    Offline

    AlexFF Разбирающийся

    Регистрация:
    6 мар 2007
    Сообщения:
    565
    Симпатии:
    1
    Баллы:
    26
    Код:
    |ИТОГИ
    |    СУММА(Стоимость)
    |ПО
    |    ОБЩИЕ";
    </span>
    
    </FONT></FONT></pre>
    ну и дальше по тексту который - ранее был

Поделиться этой страницей