7.7 Перегрузка документов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем webber, 10 фев 2008.

  1. TopicStarter Overlay
    webber
    Offline

    webber

    Регистрация:
    10 фев 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Вот. Помогите пожалуйста. Я в этом деле полный новичек. Достаточно долго изучал С++ но вот сейчас пришлость написать одну вещь с помощью языка 1С. Даже не знаю что делать.
    Задание такое: Необходимо в спомощью программных средств языка написать внешнюю обработку "Перегрузка документа". Приложил к теме файл с более подробным задание.
    Так вот. Я поставил 1С 7.7. Запустил конфигуратор создал внешнюю оболочку и на этом все встало. Не могу поняaua:
    Мог бы кто нибудь мне помочь :unsure:

    Вложения:

    • _help_.doc
      Размер файла:
      42,5 КБ
      Просмотров:
      84
  2. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    [warn=Читайте правила!]Использование слишком большого размера шрифта и заглавных букв без достаточных оснований. Даже если Вам необходимо срочно привлечь к теме/сообщению повышенное внимание, это не создаст нужного эффекта. Такие темы, как "ПОМОГИТЕ!!!", "Ищу" или "Вопрос", а также сообщения типа "Неужели никому не интересно?" или "Ответьте кто-нибудь!", будут модерироваться или удаляться без предупреждения.
    Также запрещено использование слишком вызывающего (яркого) цвета текста без подобающих оснований. Также учтите, что некоторые яркие цвета могут снизить читабельность текста.[/warn]
  3. TopicStarter Overlay
    webber
    Offline

    webber

    Регистрация:
    10 фев 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Уже сделано окно для выбора документа и открытия файла для сохранения. Может кто нибудьь помочь как поля документа правильно сохранять.

    Вложения:

    • SaveDoc.ert
      Размер файла:
      33,5 КБ
      Просмотров:
      51
  4. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Отличное задание! Обработка для 7.7, а тестировать на 8! Прекрасный труд :)
  5. TopicStarter Overlay
    webber
    Offline

    webber

    Регистрация:
    10 фев 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    ага ну эту часть я думая в юмор
  6. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Ну дык задания-то хоть дайте правильное, а то обработка на 7.7, а проверять на 8.0 - кто такое написал-то?
  7. TopicStarter Overlay
    webber
    Offline

    webber

    Регистрация:
    10 фев 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Итак простите за не точность. Я только начал разбираться с 1С. Задание файл !help.

    То что я уже сделал находиться в файле savedoc

    Не могу продвинуться с сохранением документа... И разобраться с метаданными(впринципе понятно что это, а как юзить пока не дошло)

    Вложения:

    • SaveDoc.ert
      Размер файла:
      40,5 КБ
      Просмотров:
      61
    • _help.doc
      Размер файла:
      42,5 КБ
      Просмотров:
      57
  8. ЧКДзержинский
    Offline

    ЧКДзержинский Опытный в 1С

    Регистрация:
    7 дек 2006
    Сообщения:
    487
    Симпатии:
    3
    Баллы:
    29
    Вообще то баловаться новичку с такими операциями, как перегрузка документов, лучше не стоит. Доверь это дело опытному программеру, а то дров наломаешь.
  9. TopicStarter Overlay
    webber
    Offline

    webber

    Регистрация:
    10 фев 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Всмысле. Я учусь программировать на 1С. Не могу разобраться. Прошу помочь или кинуть пример.
  10. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    [​IMG]
    Как я видел, тебе набросали примерных обработок уже :) Осталось соединить их вместе и будет все окей.

    ЗЫ. Имхо, стоит учить 8-ку - ибо она ближе к С++ будет и понятнее...
    Да и выгоднее :) 77 незнаю - не помогу, а 8 - делов на пару часов с отладкой
  11. TopicStarter Overlay
    webber
    Offline

    webber

    Регистрация:
    10 фев 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Только я не видел этих обработок. Не можешь сказать где мне их набрасали
  12. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    Что-то я не понял - у тебя двойник есть с таким вопросом, причем даже слова совпадают? :unsure:
    Смотри
  13. TopicStarter Overlay
    webber
    Offline

    webber

    Регистрация:
    10 фев 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Да я разместил свою тему на 4рех форумах. Но насколько я помню мне еще никто не кинул пример с тем чтобы можно было сохранять поля разных документов...
  14. TopicStarter Overlay
    webber
    Offline

    webber

    Регистрация:
    10 фев 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Может кто нибудь найти ошибку:
    Код:
    Для Сч=1 По Метаданные.ОбщийРеквизитДокумента() Цикл
    ТекстФайла.ДобавитьСтроку(СтрокаДляСохранения+".РеквизитШапки."+СокрЛП(ДокументДляВыгрузки.ПолучитьАтрибут(Метаданные.ОбщийРеквизитДокумента(Сч))));
    КонецЦикла; 
    
    //    Для Сч=1 По Метаданные.Документ(ДокументДляВыгрузки.Вид()).РеквизитШапки() Цикл
    //    ТекстФайла.ДобавитьСтроку(СтрокаДляСохранения+".РеквизитШапки."+СокрЛП(ДокументДляВыгрузки.ПолучитьАтрибут(Метаданные.РеквизитШапки(Сч))));
    //    КонецЦикла; 
    
    ДокументДляВыгрузки.ВыбратьСтроки();
    Пока ДокументДляВыгрузки.ПолучитьСтроку()=1 Цикл
    Для Сч=1 По Метаданные.РеквизитТабличнойЧасти() Цикл
    ТекстФайла.ДобавитьСтроку(СтрокаДляСохранения+".РеквизитТабличнойЧасти." + 
    ДокументДляВыгрузки.НомерСтроки+"." + 
    Метаданные.РеквизитТабличнойЧасти().Идентификатор + 
    СокрЛП(ДокументДляВыгрузки.ПолучитьАтрибут(Метаданные.РеквизитТабличнойЧасти(Сч))));
    КонецЦикла;
    КонецЦикла;
    
    
    
    
  15. TopicStarter Overlay
    webber
    Offline

    webber

    Регистрация:
    10 фев 2008
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    тему закрыть.

Поделиться этой страницей