7.7 Передать значение реквизита в открытую форму

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Samouchka, 10 май 2014.

  1. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Всем доброго времени суток! Хочу открыть форму обработки (Ф2) из формы документа (Ф1), а затем передать значение реквизита ДатаНалогов из Ф1 в реквизит пДатаНалогов Ф2.
  2. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Извиняюсь, тема раньше времени создалась. Пишу сначала
    Всем доброго времени суток! Хочу открыть форму обработки (Ф2) из формы документа (Ф1), а затем передать значение реквизита ДатаНалогов из Ф1 в реквизит пДатаНалогов Ф2.
    В модуле Ф1 пишу код:
    Код:
    Процедура СоздатьНалоги()
        Перем Конт;
             _Контекст=глВзятьКонтекст(Конт);
                ОткрытьФорму("Обработка.ПлатежкиЗарплаты", Конт);
      КонецПроцедуры
    В модуле Ф2 пишу:
    Код:
    Перем Конт;
    Перем _Контекст;
     
    Процедура ПриОткрытии()
    пДатаНалогов=Конт.ДатаНалогов;
    КонецПроцедуры
     
    Конт=_Контекст;
    В глобальном модуле пишу:
    Код:
    Функция глВзятьКонтекст(Конт) Экспорт
        Возврат Конт;
    КонецФункции // глВзятьКонтекст()
    При исполнении процедуры СоздатьНалоги() натыкаюся на ошибку:
    пДатаНалогов=Конт.ДатаНалогов;
    {Обработка.ПлатежкиЗарплаты.Форма.Модуль(7)}: Значение не представляет агрегатный объект (ДатаНалогов)
    Помогите, пожалуйста
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    Процедура СоздатьНалоги()
             _Контекст=глВзятьКонтекст(Контекст);
               ОткрытьФорму("Обработка.ПлатежкиЗарплаты", _Контекст);
      КонецПроцедуры
    
  4. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Та же ошибка
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    ДатаНалогов это реквизит документа или просто реквизит формы?
  6. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Отбой этой теме. Я разобрался. Передал через конструкцию Форма.Параметр ссылку на текущий документ, а в форме обработки из этой ссылки извлек то что мне нужно. Почему через контекст не вышло, не знаю
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    а так?
    ОткрытьФорму("Обработка.ПлатежкиЗарплаты", Контекст);

Поделиться этой страницей