7.7 Передать параметр

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем igorekkrav, 27 авг 2010.

  1. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    Подскажите как передать параметр в форму. У меня есть поле ввода которое открывает справочник как туда передать параметр . :unsure:
  2. Time dont wait
    Offline

    Time dont wait Опытный в 1С

    Регистрация:
    20 окт 2009
    Сообщения:
    192
    Симпатии:
    0
    Баллы:
    26
    Делаеш кнопку, к ней процедуру:
    Код:
    Процедура ПередачаПараметра()
    конт=НужноеЗначениеИлиРеквизитНаФормеИлиЧтоНибудьДругое;
    ОткрытьФорму("ДопустимСправочник.Такойто",конт);
    КонецПроцедуры
    
    
    А в справочнике
    Код:
     
    Процедура ПриОткрытии()
    ПередаваемоеЗначение=Форма.Параметр;
    //подставляеш его куда тебе нужно, или делаеш какую-нибудь проверку
    КонецПРоцедуры
    
  3. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    С кнопкой я так сделал .А вот с полем ввода не пойму . При нажатие на поле ввода у меня будет открываться справочник клиентов . (для выбора значения из справочника ). Но и туда должно передаться значение . Я думал нужно как то через эту
    Код:
    Процедура ПриНачалеВыбораЗначения(Элемент,Флаг)
    
  4. Time dont wait
    Offline

    Time dont wait Опытный в 1С

    Регистрация:
    20 окт 2009
    Сообщения:
    192
    Симпатии:
    0
    Баллы:
    26
    Можно и так, вродь:
    Код:
    Процедура ПриНачалеВыбораЗначения(Парам) 
    Если Парам = "нужноезначение"  Тогда 
    Твой = СоздатьОбъект("Справочник.Твой"); 
    //использование параметра
    КонецЕсли; 
    КонецПроцедуры
    
  5. TopicStarter Overlay
    igorekkrav
    Offline

    igorekkrav Опытный в 1С

    Регистрация:
    29 апр 2010
    Сообщения:
    223
    Симпатии:
    0
    Баллы:
    26
    спасибо получилось :)

Поделиться этой страницей