8.х Передать и вставить значение в ФормыВыбора

Тема в разделе "Установка платформы "1С:Предприятие 8"", создана пользователем GiGi, 18 июн 2017.

  1. TopicStarter Overlay
    GiGi
    Offline

    GiGi

    Регистрация:
    7 мар 2017
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Всем привет!
    Сталкнулся с проблемой ... требуеться Ваша помощь.
    Нужно два раза запустить ФормуВыбора и в самим вставленные поля пойска каждой вставить нужное значения выбора элемента.
    Внизу процедура кнопки.
    И дело в том, что то, что обозначенно коментарием: "ЗАПУСК 1" работает нормально. Т.е. когда форма открылась нужное значение успешно всавляеться в нужное поле Формы на верхней ее панели.
    Но уже во втором случае (в месте обозначеном: "ЗАПУСК 2"), никак не получаеться получить то же самое, что и при ЗАПУСКЕ 1
    Т.е. переменные в: Предупреждение(ОБЪЕКТимя+" -- "+знТочкаСнабжения); передаются, но вторая: "ТочкаСнабжения" НУ НИКАК НЕ ВСТАВЛЯЕТЬСЯ в поле формы: "ТочкаСнабжения"
    Не пойму в чем причина.
    Рассчитываю на Вашу помощь

    Код:
    &НаКлиенте
    Процедура СубТочка_Выбрать(Команда)
    Если Объект.Код = ""  Тогда
    Предупреждение("Для определения суб-точек учета объект не сохранен!");
    Перейти ~Выход;
    Иначе
    ОБЪЕКТимя=Объект.Найменование;
    КонецЕсли;
    //=============== ЗАПУСК 1 ============================
    ФормаВыбор_ТочкаСнабжение=ПолучитьФорму("Справочник.ТОЧКА.ФормаВыбора",,ЭтаФорма);
    ФормаВыбор_ТочкаСнабжение.ОбъектПринадлежности=ОБЪЕКТимя;
    //-------------------------------------------
    Выбор_ТочкаСнабжение = ФормаВыбор_ТочкаСнабжение.ОткрытьМодально();
    //=====================================================
    Если Выбор_ТочкаСнабжение <> Неопределено Тогда
    //=============== ЗАПУСК 2 ============================
    знВыборПолучить = ПолучитьФорму("Справочник.ТОЧКА.ФормаОбъекта", новый Структура("Ключ", Выбор_ТочкаСнабжение));
    знТочкаСнабжения=знВыборПолучить.Объект.Найменование;
    //################## ФРАГМЕНТ КОДА ДЛЯ ИСПРАВЛЕНИЯ #############################
    ФормаВыбор_ТочкаПодключение = ПолучитьФорму("Справочник.ТОЧКА.ФормаВыбора",,); //ФормаВыбор_ТочкаПодключение = ПолучитьФорму("Справочник.ТОЧКА.Форма.ФормаВыбора",,);
    //ТУТ ПОЛЕ ФормыВыбора: "ТочкаСнабжения", НУ НИКАК НЕ ХОЧЕТ ПРИНИМАТЬ ЗНАЧЕНИЕ ПЕРЕМЕННОЙ; "ТочкаСнабжения". НИКАК ЗАРАЗА!
    //УЖЕ ПРИ ВТОРОМ ЗАПУСКЕ ФормыВыбора ПРОСТО ИГНОРИРУЕТ ЕЕ ... ПРОПУСКАЕТ
    ФормаВыбор_ТочкаПодключение.ТочкаСнабжения=знТочкаСнабжения;
    ФормаВыбор_ТочкаПодключение.Открыть();
    Предупреждение(ОБЪЕКТимя+" -- "+знТочкаСнабжения);
    //################## ФРАГМЕНТ КОДА ДЛЯ ИСПРАВЛЕНИЯ #############################
    КонецЕсли;
    //===========================================
    ~Выход:;
    КонецПроцедуры
    
    Буду очень признателен Вам!
    Последнее редактирование: 18 июн 2017

Поделиться этой страницей