8.х передать данные на форму и получить результат выбора на форме в модуль?

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Ленок87, 16 янв 2013.

  1. TopicStarter Overlay
    Ленок87
    Offline

    Ленок87 Опытный в 1С

    Регистрация:
    7 фев 2012
    Сообщения:
    261
    Симпатии:
    0
    Баллы:
    26
    Обычное приложение 1с 8.2 БП
    Необходимо при нажатии на кнопку на форме документа вывести окно обработки для выбора клиентом контрагентов (которых нужно взять из табличной части документа)

    Как передать в форму обработки список контрагентов из таб части
    в 1с 7
    СписокПольз=СоздатьОбъект("СписокЗначений");
    ВыгрузитьТабличнуюЧасть(СписокПольз,"Контрагент");
    ОткрытьФормуМодально("Обработка._ПечатьАктов",СписокПольз);
    Если ТипЗначенияСтр(СписокПольз)="СписокЗначений" Тогда
    СоздатьДокументыСчет(СписокПольз);



    А потом из формы ,в которой клиент выбирает контрагентов вернуть выбранные для напечатывания документа
    в 1с 7

    Процедура ПриОткрытии()
    Список = Форма.Параметр;
    Для сч=1 По Список.РазмерСписка() Цикл
    СписокПользователей.ДобавитьЗначение(Список.ПолучитьЗначение(сч));
    СписокПользователей.Пометка(сч,1)
    КонецЦикла;
    Форма.Параметр = 0;
    КонецПроцедуры
  2. Doza
    Offline

    Doza

    Регистрация:
    16 янв 2013
    Сообщения:
    33
    Симпатии:
    0
    Баллы:
    1
    ВЫгружаешь колонку контрагент, получаешь массив. И загружаешь этот массив в список значений.
    далее КонтрагентыВыбраны = СписокЗначений.ОтметитьЭлементы();
    Откроется окно где можно проставить галочки напротив каждого контрагента. Свойство списка Пометка будет равна Истина, если выбрали этого контрагента.
    Потом в цикле пробегаешся по элементам списка и смотришь где пометка истина, или можно использовать свойство списка НайтиСтроки(<ПараметрыОтбора>).
    ВОт описание из СП.


    СписокЗначений (ValueList)
    ОтметитьЭлементы (CheckItems)

    Синтаксис:
    ОтметитьЭлементы(<Заголовок>)

    Параметры:

    <Заголовок> (необязательный)
    Тип: Строка.
    Заголовок окна диалога. Если параметр не указан, то используется стандартный заголовок.
    Значение по умолчанию: Пустая строка

    Возвращаемое значение:
    Тип: Булево.
    Истина - в диалоге пометки нажата кнопка "ОК"; Ложь - в противном случае.

    Описание:
    Устанавливает или снимает (интерактивно) пометки у элементов списка значений.


    Доступность:
    Тонкий клиент, веб-клиент, толстый клиент.

    Пример:
    Если СписокТиповЦен.ОтметитьЭлементы("Удаляемые типы цен.") Тогда
    Для каждого Элемент из СписокТиповЦен Цикл
    Если Элемент.Пометка Тогда
    Элемент.Значение.ПолучитьОбъект().
    УстановитьПометкуУдаления(Истина);
    КонецЕсли;
    КонецЦикла;
    Иначе
    Сообщить("Отказ от пометки на удаление типов цен.");
    КонецЕсли;

Поделиться этой страницей