8.х Передача значения переменной от сервера на клиент

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Arty585, 30 авг 2017.

  1. TopicStarter Overlay
    Arty585
    Offline

    Arty585

    Регистрация:
    30 авг 2017
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Дано такое задание: Если константа Подтверждение = Истина, то вопрос о завершении работы системы выводится, а если Подтверждение = Ложь, то программа будет завершаться без вопроса.

    Мой код:

    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Константы.Подтверждение.Установить(Истина);
    Подтверждение=Константы.Подтверждение.Получить();
    КонецПроцедуры

    &НаКлиенте
    Процедура ПередЗавершениемРаботыСистемы(Отказ)


    Если ПриСозданииНасервере(Подтверждение) = Истина тогда
    Ответ = Вопрос("Заверишь работу с программой?",РежимДиалогаВопрос.ДаНет,,,"Внимание!",);
    Отказ = (Ответ=КодВозвратаДиалога.Нет);
    КонецЕсли
    КонецПроцедуры

    Пишет процедура ПриСозданииНаСервере не определена.
    Обьясните как передать значение константы от сервера клиенту.
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    9.405
    Симпатии:
    973
    Баллы:
    204
    Летели 2 крокодила: один зеленый, а другой - в Африку.......
    TrasserZero нравится это.
  3. Aleks.G
    Offline

    Aleks.G

    Регистрация:
    24 июн 2017
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Вам надо объявить экспортную функцию в общем модуле с серверными вызовами для получения значения константы и потом в модуле упр. приложения в процедуре ПередЗавершениемРаботыСистемы в условии вызвать функцию и обработать результат.

Поделиться этой страницей