7.7 Передача данных по времени

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем TRABANT, 10 окт 2011.

  1. TopicStarter Overlay
    TRABANT
    Offline

    TRABANT

    Регистрация:
    17 сен 2011
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    Есть такая задумка что бы данные переносились из одного докумена в другой по времени.
    т.е. есть док-ты "счет" нужно сделать что бы создавались док-ты "перемещние материалов" использую даные док0ты счет..
    Никак не пойму как сделать..Для одного документа получаеться а вот кака вделать выборку по временной шкале.По дате док-та не выйдет т.к. у них одиноковые даты,только разно время..Или может проще по номеру?(см.скрин)

    Код:
    Процедура Выполнить()                         
    
    //табЗн = создатьОбъект("ТаблицаЗначений"); (добавлена на форму)
    //////***заполнение Тз данными из источника***\\\\\\   
    
    тз.новаяКолонка("Код","число");
    тз.новаяколонка("товар","справочник.номенклатура"); 
    тз.новаяколонка("количество","число");
    
    
    док = создатьобъект("документ.счет"); 
    Ч = 0;
    М = 0;
    С = 0;  
    Док.ПолучитьВремя(Ч, М, С); // Прочтем время 
    
    сообщить (""+ч); 
    сообщить (""+м);
    сообщить (""+с);
    
    
    док.выбратьдокументы();
    
    
    сообщить ("док="+док); 
    
    пока док.получитьстроку()=1 цикл 
    
    тз.новаястрока();
    тз.код=док.номерстроки;
    тз.товар=док.товар;                         
    тз.количество = док.количество;
    
    конецЦикла;
    
    ////***передача данных в документ цель ***\\\             
    
    открытьформу("Документ.новый2",Тз);
    
    
    КонецПроцедуры
    
    
    Код:
    Процедура ПриОткрытии()
    ПриЗаписиПерепроводить(1); 
    Табзн=форма.параметр;  
    
    ЗагрузитьТабличнуюЧасть(ТабЗн);
    КонецПроцедуры
    
    

    Вложения:

  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    вам нужно загрузить в один документ перемещение все счета за определенный промежуток времени?
  3. TopicStarter Overlay
    TRABANT
    Offline

    TRABANT

    Регистрация:
    17 сен 2011
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    на каждый документ "счет" создавался докумнт "перемещение материалов" используя данные из документа счет .
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    Ч=0;
    М=0;
    С=0;
    Док=СоздатьОбъект("Документ.Счет");
    Док.ВыбратьДокументы(Дат,Дат);
    Пока Док.ПолучитьДокумент()=1 Цикл
    
    Док.ПолучитьВремя(Ч,М,С);
    Если (Ч>=НужныйЧасМин)И(Ч<=НужныйЧасМакс) Тогда
    //здесть создаем перемещение
    КонецЕсли;
    КонецЦикла;
    
    
  5. TopicStarter Overlay
    TRABANT
    Offline

    TRABANT

    Регистрация:
    17 сен 2011
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    спасибо за советы:)

Поделиться этой страницей