7.7 Перебрать колонки таблицы значений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Samouchka, 27 фев 2015.

  1. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Приветствую всех. Впервые столкнулся с необходимостью перебирать колонки таблицы значений, а не обращаться к ним напрямую через идентификаторы. Нужно получить колонку с определённым номером, который равен переменной в цикле. ТЗ создавалась без идентификаторов колонки. В конфигураторе сказано, что в этом случае к колонке можно обратиться только по ее номеру. Как? Вот в чём вопрос. Помогите, пожалуйста дописать последнии строки кода:

    Код:
    //Подготовим таблицу значений нужных размеров
        Для Сч=1 По ВысотаКапчи Цикл
            ТЗ.НоваяСтрока();
        КонецЦикла;
      
        Для Сч=1 По ДлинаКапчи Цикл
            ТЗ.НоваяКолонка(,,,"Столбец "+Сч,,,,);
        КонецЦикла;
    
        //работаем с текстовым файлом и заполняем таблицу  
       Для Н = 1 По Текст2.КоличествоСтрок() Цикл
          Ст  = Текст2.ПолучитьСтроку(Н);
             Если СтрДлина(Ст) > 0 Тогда
                 //узнаем номер строки и номер столбца
            Если Н/ДлинаКапчи=Цел(Н/ДлинаКапчи) Тогда
                НомСтр=Н/ДлинаКапчи;
                НомерСтолбца=Н/НомСтр;
            КонецЕсли;
            Если Н/ДлинаКапчи>Цел(Н/ДлинаКапчи) Тогда
                //если столкнулись с первой строкой
                Если Цел(Н/ДлинаКапчи)=0 Тогда
                    НомСтр=1;
                    НомерСтолбца=Н;
                КонецЕсли;
                //продолжение
                Если Цел(Н/ДлинаКапчи)>0 Тогда
                    НомСтр=Цел(Н/ДлинаКапчи)+1;
                    НомерСтолбца=Н-Цел(Н/ДлинаКапчи)*ДлинаКапчи;
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
         //непосредственно заполняем таблицу
         ТЗ.ПолучитьСтрокуПоНомеру(НомСтр);
             ТЗ.=Ст;//тут надо обратиться к колонке, номер которой равен НомерСтолбца
       КонецЦикла;
  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    тз.получитьзначение(номстр,номстлб) //прочитать
    тз.установитьзначение(номстр,номстлб,значен) //присвоить
    Последнее редактирование: 27 фев 2015
    Samouchka нравится это.
  3. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Премного благодарен:)

Поделиться этой страницей