7.7 Перебор всех документов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем mhl, 17 июл 2008.

  1. TopicStarter Overlay
    mhl
    Offline

    mhl Опытный в 1С

    Регистрация:
    23 июн 2007
    Сообщения:
    418
    Симпатии:
    0
    Баллы:
    26
    Народ помогите!!!
    Необходимо в написать обработку, которая переберет все документы и при необходимости изменит значение фирмы. Например если стоит фирма А ее надо изменить на Б.
    Очень долгое время не работал на семерке и уже успел многое забыть. Кто знает пожалуйста помогите.
    Заранее спасибо
  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    на диске итс есть обработка по замене значений
  3. TopicStarter Overlay
    mhl
    Offline

    mhl Опытный в 1С

    Регистрация:
    23 июн 2007
    Сообщения:
    418
    Симпатии:
    0
    Баллы:
    26
    на каком диске, за какой месяц?
    ели у тебя она есть дай пожалуйста
  4. Kaboom
    Offline

    Kaboom Опытный в 1С

    Регистрация:
    2 июл 2007
    Сообщения:
    158
    Симпатии:
    0
    Баллы:
    26
    НачДата, КонДата, СтарФирма, НовФирма - реквизиты диалога

    Код:
    Процедура Сформировать()
    Док = СоздатьОбъект("Документ");
    ДокумЗапись = СоздатьОбъект("Документ");
    Док.Выбрать(НачДата, КонДата);
    Пока Док.ПолучитьДокумент() = 1 Цикл
    //проверим есть ли в шапке документа реквизит фирма
    Реквизит=Метаданные.Документ(Док.Вид()).РеквизитШапки("Фирма");
    Если Реквизит.Выбран()=1 Тогда
    Если Док.Фирма = СтарФирма Тогда
    ДокумЗапись.НайтиДокумент(Док.ТекущийДокумент());
    ДокумЗапись.Фирма = НовФирма;
    ДокумЗапись.Записать()              //Здесь, возможно, нужно поставить Провести() - сам смотри по задаче
    КонецЕсли;
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    
  5. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Диск №1 за любой месяц, даже несколькогодичной давности.
  6. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26

Поделиться этой страницей