7.7 Перебор справочника

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Saxarok, 11 ноя 2015.

  1. TopicStarter Overlay
    Saxarok
    Offline

    Saxarok

    Регистрация:
    31 мар 2009
    Сообщения:
    9
    Симпатии:
    0
    Баллы:
    1
    Добрый день!
    Подскажите как, без запроса, перебрать Спр.Товары по группам
    Нашла такой кусок кода, но не пойму почему не срабатывает:

    Меню=СоздатьОбъект("СписокЗначений");
    Меню.ДобавитьЗначение(1,"Все товары на складе");
    Меню.ДобавитьЗначение(2,"Группа товаров (один товар)");
    Зн1=0;
    Рез=Меню.ВыбратьЗначение(Зн1,"",,30,1);
    Если Рез=0 Тогда
    Возврат;
    КонецЕсли;
    ВыбТовар=ПолучитьПустоеЗначение("Справочник.Товары");
    Если Зн=2 Тогда
    СТ=СоздатьОбъект("Справочник.Товары");
    Если СТ.Выбрать("Группа или товар для отбора","ДляПодбора")=0 Тогда
    Возврат;
    КонецЕсли;
    ВыбТовар=СТ.ТекущийЭлемент();
    КонецЕсли;
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Что значит "по группам"?
    Посмотрите в СП метод ИспользоватьРодителя

Поделиться этой страницей