7.7 Перебор справочника Номенклатура

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Inkeeper, 5 сен 2011.

  1. TopicStarter Overlay
    Inkeeper
    Offline

    Inkeeper Опытный в 1С

    Регистрация:
    22 мар 2009
    Сообщения:
    327
    Симпатии:
    0
    Баллы:
    26
    Пишу перебор в ТиС справочника Номенклатуры с ценами. В ТиС 2 типа базовых цен: "Закупочная" и "СЦ".
    Мой код:
    Код:
    СпрН = СоздатьОбъект("Справочник.Номенклатура");
    СпрТЦ = СоздатьОбъект("Справочник.ТипыЦен");
    СпрЦ = СоздатьОбъект("Справочник.Цены");
    
    СпрН.ВыбратьЭлементы();
    
    Пока  СпрН.ПолучитьЭлемент()=1 Цикл
    Товар = СпрН.ТекущийЭлемент();
    СпрЦ.ИспользоватьВладельца(Товар); 
    СпрЦ.ИспользоватьДату(ТекущаяДата());
    СпрЦ.ВыбратьЭлементы();
    Пока СпрЦ.ПолучитьЭлемент()=1 Цикл
    ТипЦены = СпрЦ.ТипЦен;//!!!!
    Цена = СпрЦ.Цена;    
    Наименование = СпрЦ.Владелец.Наименование;
    Код = СпрЦ.Владелец.Код;
    РодительНом = СпрЦ.Владелец.Родитель;
    Сообщить(Код+";"+Наименование+";"+РодительНом+";"+Цена+";");
    
    КонецЦикла;
    КонецЦикла;
    
    соответственно, у меня формируется в сообщениях следующее:
    т.е. первая и вторая строка - один и тот же товар, но с разными значениями цен (1-я - закупочная, 2-я - СЦ). Как изменить код, чтобы СЦ выводилась справа от закупочной?

    т.е.
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Типа так:
    Код:
    СпрН = СоздатьОбъект("Справочник.Номенклатура");
    СпрТЦ = СоздатьОбъект("Справочник.ТипыЦен");
    СпрЦ = СоздатьОбъект("Справочник.Цены");
    
    СпрН.ВыбратьЭлементы();
    
    Пока  СпрН.ПолучитьЭлемент()=1 Цикл
    Товар = СпрН.ТекущийЭлемент();
    СпрЦ.ИспользоватьВладельца(Товар); 
    СпрЦ.ИспользоватьДату(ТекущаяДата());
    СпрЦ.ВыбратьЭлементы();
    СтрокаЦен = "";
    Пока СпрЦ.ПолучитьЭлемент()=1 Цикл
    ТипЦены = СпрЦ.ТипЦен;//!!!!
    Цена = СпрЦ.Цена;    
    Наименование = СпрЦ.Владелец.Наименование;
    Код = СпрЦ.Владелец.Код;
    РодительНом = СпрЦ.Владелец.Родитель;
    СтрокаЦен = СтрокаЦен + Цена+";"
    КонецЦикла;
    Сообщить(Код+";"+Наименование+";"+РодительНом+";"+СтрокаЦен);
    КонецЦикла;
    
  3. volodya1122
    Offline

    volodya1122 Опытный в 1С

    Регистрация:
    25 фев 2011
    Сообщения:
    96
    Симпатии:
    1
    Баллы:
    26
    Код:
    СпрН = СоздатьОбъект("Справочник.Номенклатура");
    СпрТЦ = СоздатьОбъект("Справочник.ТипыЦен");
    СпрЦ = СоздатьОбъект("Справочник.Цены");
    
    СпрН.ВыбратьЭлементы();
    
    Пока  СпрН.ПолучитьЭлемент()=1 Цикл
    Товар = СпрН.ТекущийЭлемент();
    СпрЦ.ИспользоватьВладельца(Товар); 
    СпрЦ.ИспользоватьДату(ТекущаяДата());
    СпрЦ.ВыбратьЭлементы();
    ВремНом=1;
    Пока СпрЦ.ПолучитьЭлемент()=1 Цикл
    ТипЦены = СпрЦ.ТипЦен;//!!!!
    Цена = СпрЦ.Цена;    
    Наименование = СпрЦ.Владелец.Наименование;
    Код = СпрЦ.Владелец.Код;
    РодительНом = СпрЦ.Владелец.Родитель;
    
    Если ВремНом=1 тогда
    Выводить=Код+";"+Наименование+";"+РодительНом+";"+Цена+";  ");
    Иначе
    Выводить=Выводить + Цена;
    КонецЕсли;
    ВремНом=ВремНом+1;  
    КонецЦикла;
    Сообщить (""+Выводить);
    КонецЦикла;
    
    
Похожие темы
  1. Омский домовой
    Ответов:
    2
    Просмотров:
    1.495
  2. Boyd_Rice
    Ответов:
    8
    Просмотров:
    3.667
  3. GTAlex
    Ответов:
    4
    Просмотров:
    1.832
  4. new1
    Ответов:
    3
    Просмотров:
    1.609
  5. n.s.gnedash
    Ответов:
    1
    Просмотров:
    476
Загрузка...

Поделиться этой страницей