7.7 Перебор символов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Flamepayne, 30 мар 2011.

  1. TopicStarter Overlay
    Flamepayne
    Offline

    Flamepayne Опытный в 1С

    Регистрация:
    16 мар 2011
    Сообщения:
    113
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте уважаемые, вопрос такой. Как перебрать строку посимвольно?
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Ознакомься с оператором "Для ... Цикл ... КонецЦикла" и функцией "Сред()"
  3. sergejk74
    Offline

    sergejk74 Опытный в 1С

    Регистрация:
    15 ноя 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Код:
    	Длина = СтрДлина(ДатаНомерСчетаФактуры);
    
    Для йй=1 По Длина Цикл
    Символ = Сред(ДатаНомерСчетаФактуры,йй,1); 
    КонецЦикла;
    
    Переберет переменную ДатаНомерСчетаФактуры
  4. TopicStarter Overlay
    Flamepayne
    Offline

    Flamepayne Опытный в 1С

    Регистрация:
    16 мар 2011
    Сообщения:
    113
    Симпатии:
    0
    Баллы:
    26
    Всем спасибо, нашел необходимый метод. У меня теперь др вопрос: В справочнике имеется код и наименование как по определенному коду вывести соответствующее наименование?
  5. sergejk74
    Offline

    sergejk74 Опытный в 1С

    Регистрация:
    15 ноя 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Код:
    	Спр = СоздатьОбъект("Справочник.Номенклатура");
    КодДляПоиска="000001";
    Если спр.НайтиПоКоду(КодДляПоиска)=1 Тогда
    Сообщить(спр.Наименование);
    КонецЕсли;
    
    Тебе это нужно?
  6. TopicStarter Overlay
    Flamepayne
    Offline

    Flamepayne Опытный в 1С

    Регистрация:
    16 мар 2011
    Сообщения:
    113
    Симпатии:
    0
    Баллы:
    26
    Угу, спасибо =)
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Для "спасибо" есть кнопочка... если ответ помог решить проблему.
    И вам хорошо и человеку приятно)))))))

Поделиться этой страницей