[РЕШЕНО] Перебор имен колонок в цикле

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Poverina, 14 мар 2014.

  1. TopicStarter Overlay
    Poverina
    Offline

    Poverina

    Регистрация:
    14 фев 2014
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте. Есть цикл, который должен подставлять в имена колонок значения от 1 до 31.

    Код:
    Для Счетчик = 1 По 31 Цикл
           ...
           ЧМ = ЧМ + Строка.Часы[Счетчик];
          ...
    КонецЦикла;   
    При выполнении выдает ошибку:

    Как в имя колонки правильно подставить значение Счетчика?
  2. Thelearning
    Offline

    Thelearning Профессионал в 1С Команда форума

    Регистрация:
    9 сен 2010
    Сообщения:
    701
    Симпатии:
    72
    Баллы:
    54
    Попробуйте так
    Код:
    Для Счетчик = 1 По 31 Цикл
           ...
           ЧМ = ЧМ + Строка.["Часы" + Строка(Счетчик)];
          ...
    КонецЦикла;
  3. TopicStarter Overlay
    Poverina
    Offline

    Poverina

    Регистрация:
    14 фев 2014
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Если так, то начинает выдавать ошибки:

    Вот сам цикл полностью:

    Код:
    Для Счетчик = 1 По 31 Цикл       
           Если Строка.Колонка1 = "Я" Тогда
             ф = ф+1;
             ЧМ = ЧМ + Строка.["Часы" + Строка(Счетчик)];
             РЧ = РЧ + Строка.Часы1;
             Если Число(Строка.Часы1) > 8 Тогда
               ПР = ПР + (Строка.Часы1 - 8);
               РЧ = 8;
             КонецЕсли;   
           ИначеЕсли Строка.Колонка1 = "ОТ" Тогда
             ОТ = ОТ + 1;
           ИначеЕсли Строка.Колонка1 = "Б" Тогда
             Б = Б + 1;   
           ИначеЕсли Строка.Колонка1 = "РВ" Тогда
             ф = ф+1;
             ЧМ = ЧМ + Строка.Часы1;
             РВ = РВ + Строка.Часы1;
           ИначеЕсли Строка.Колонка1 = "К" Тогда
             К = К + 1;
             ф = ф+1;
             ЧМ = ЧМ + Строка.Часы1;
             Если Число(Строка.Часы1) > 8 Тогда  
               ПР = ПР + (Строка.Часы1 - 8);
               РЧ = 8;
             КонецЕсли;
           КонецЕсли;
       КонецЦикла;
    
  4. Thelearning
    Offline

    Thelearning Профессионал в 1С Команда форума

    Регистрация:
    9 сен 2010
    Сообщения:
    701
    Симпатии:
    72
    Баллы:
    54
    Чуть неверно я написал. Точку уберите.
    Код:
    ЧМ = ЧМ + Строка["Часы" + Строка(Счетчик)];
    Poverina нравится это.
  5. TopicStarter Overlay
    Poverina
    Offline

    Poverina

    Регистрация:
    14 фев 2014
    Сообщения:
    31
    Симпатии:
    0
    Баллы:
    1
    Вот так работает, благодарю

Поделиться этой страницей