8.х Перебор и выгрузка элементов справочника в файл

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем GTAlex, 7 фев 2012.

  1. TopicStarter Overlay
    GTAlex
    Offline

    GTAlex

    Регистрация:
    21 мар 2008
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Снова ньюбские вопросы от семёрошника

    я так понимаю выгружать нужно &НаКлиенте а данные получать &НаСервере (т.к. обратиться к Справочники.Контрагенты из &НаКлиенте у меня не получилось)

    собственно теперь вопрос - как правильно передать выборку ?

    (или вообще посоветуйте - как в 1С 8.2 идеологически правильно сделать данную операцию)

    Код:
    &НаКлиенте
    Процедура Сформировать(Команда)
    
    НовыйФайл = Новый ЗаписьТекста(ПутьКФайлу, КодировкаТекста.ANSI, Символы.ПС);
    
    Выборка = Новый ?????;
    Выборка = ПолучитьДанные();
    
    Пока Выборка.Следующий() Цикл
    Объект = Выборка.ПолучитьОбъект();
    НовыйФайл.ЗаписатьСтроку(""" + Объект._КОД + "","" + Объект.ИНН + """);
    КонецЦикла;
    
    НовыйФайл.Закрыть();
    
    КонецПроцедуры
    
    
    &НаСервере
    Функция ПолучитьДанные()
    Контрагенты = Справочники.Контрагенты;
    Выборка = Контрагенты.Выбрать(,,,);
    
    Возврат Выборка;
    КонецФункции
    
  2. TopicStarter Overlay
    GTAlex
    Offline

    GTAlex

    Регистрация:
    21 мар 2008
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Забыл в теме добавить категорию вопроса - "1С 8.2 УП"
  3. TopicStarter Overlay
    GTAlex
    Offline

    GTAlex

    Регистрация:
    21 мар 2008
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Незнаю - правильно, или нет, но вроде как идея такова:

    Вяжем кнопку с процедурой &НаКлиенте, и оттуда сразу вызываем нужную обработку &НаСервере - там уже делать выборку и сохранять.

    Код:
    &НаКлиенте
    Процедура Сформировать(Команда)
    СформироватьФайл();
    КонецПроцедуры
    
    &НаСервере
    Процедура СформироватьФайл()
    
    // выбираем, то что нужно и сохраняем
    
    КонецПроцедуры
    
  4. TopicStarter Overlay
    GTAlex
    Offline

    GTAlex

    Регистрация:
    21 мар 2008
    Сообщения:
    7
    Симпатии:
    0
    Баллы:
    1
    Хотя всё-же интересно было бы узнать как передать выборку ?
    Первое что приходит на ум - через ТаблицуЗначений, но чувствую - должен быть более элегантный спобос
  5. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    На клиент не может существовать выборки. Да и не очень понятно, зачем она так. Поясните.

Поделиться этой страницей